Bug 1287853 - External Authentication configuration fails after setting hostname in appliance console
External Authentication configuration fails after setting hostname in applian...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
x86_64 Linux
unspecified Severity high
: GA
: 5.5.2
Assigned To: Nick Carboni
Dmitry Misharov
: ZStream
Depends On: 1286830
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 15:40 EST by John Prause
Modified: 2016-02-10 10:21 EST (History)
9 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286830
Environment:
Last Closed: 2016-02-10 10:21:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2015-12-09 14:28:34 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=037d8007fcfdfde47afa5cf4626b0c277e9dfd3a

commit 037d8007fcfdfde47afa5cf4626b0c277e9dfd3a
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Fri Dec 4 13:33:50 2015 -0500
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Wed Dec 9 08:49:53 2015 -0500

    Altered the console to set the canonical hostname rather than an alias
    
    The /etc/hosts man page describes a difference between the "canonical_hostname"
    (fqdn) and the aliases for that hostname.
    
    This difference is reflected in the behaviour of some external tools such
    as cloud-init and freeipa.
    These tools will retrieve the hostname (typically via the hostname
    command or from /etc/hostname) then consult /etc/hosts to find the
    fqdn by taking the name in the "canonical_hostname" place in the line
    where the found hostname is an alias.
    
    This can cause problems when the application acts differently based on
    whether the fqdn is "localhost" or not.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287853

 gems/pending/Gemfile              | 2 +-
 gems/pending/appliance_console.rb | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 4 CFME Bot 2015-12-09 14:28:39 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a0403d3cd07a01d3ad9aaf1c00f88c3e73f34f73

commit a0403d3cd07a01d3ad9aaf1c00f88c3e73f34f73
Merge: 4425510 f9eba94
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Wed Dec 9 14:24:24 2015 -0500
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Wed Dec 9 14:24:24 2015 -0500

    Merge branch 'backport_console_canonical_hostname' into '5.5.z'
    
    Altered the console to set the canonical hostname rather than an alias
    
    The /etc/hosts man page describes a difference between the "canonical_hostname"
    (fqdn) and the aliases for that hostname.
    
    This difference is reflected in the behaviour of some external tools such
    as cloud-init and freeipa.
    These tools will retrieve the hostname (typically via the hostname
    command or from /etc/hostname) then consult /etc/hosts to find the
    fqdn by taking the name in the "canonical_hostname" place in the line
    where the found hostname is an alias.
    
    This can cause problems when the application acts differently based on
    whether the fqdn is "localhost" or not.
    
    Clean cherry-pick from upstream master
    
    Upstream PR: https://github.com/ManageIQ/manageiq/pull/5714
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287853
    
    See merge request !590

 gems/pending/Gemfile                      | 2 +-
 gems/pending/appliance_console.rb         | 2 +-
 spec/models/miq_server/rhn_mirror_spec.rb | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)
Comment 6 Dmitry Misharov 2016-01-20 04:51:47 EST
Verified fixed in 5.5.2.1.20160114044944_395c086. When configuring the hostname in appliance_console you should specify FQDN.

In addition during verifying the bug I encountered with this problem  https://bugzilla.redhat.com/show_bug.cgi?id=1292146. Workaround of this is downgrading ipa-client, ipa-python, ipa-admintools packages to the same version of ipa-server package which is installed on the ipa server.
Comment 7 errata-xmlrpc 2016-02-10 10:21:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.