Bug 1287864 - On Wayland, Minecraft crashes on startup
On Wayland, Minecraft crashes on startup
Status: CLOSED DUPLICATE of bug 1236389
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mario Torre
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2015-12-02 16:10 EST by Michael Wiktowy
Modified: 2015-12-16 09:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 09:00:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash report on opening Minecraft under Wayland (1.76 KB, text/plain)
2015-12-02 16:10 EST, Michael Wiktowy
no flags Details

  None (edit)
Description Michael Wiktowy 2015-12-02 16:10:41 EST
Created attachment 1101622 [details]
crash report on opening Minecraft under Wayland

Description of problem:
When minecraft is started with the starting script:
#!/bin/bash
export LD_LIBRARY_PATH="/usr/lib/jvm/jre-1.8.0/lib/amd64"
java -jar /home/mwiktowy/bin/minecraft/minecraft.jar

or from the command line simply using:
java -jar /home/mwiktowy/bin/minecraft/minecraft.jar

the launcher starts but when the main program attempts to load, it crashes into the error reporting dialog.

Version-Release number of selected component (if applicable):
Minecraft Version: 1.8.8
Operating System: Linux (amd64) version 4.2.6-301.fc23.x86_64
Java Version: 1.8.0_65, Oracle Corporation
Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Oracle Corporation
LWJGL: 2.9.4

How reproducible:
Always

Steps to Reproduce:
1. Launch Minecraft
2. crash after launcher tries to load game

Actual results:
Crash and error report (see attached)

Expected results:
Launch of game since minecraft runs fine on non-Wayland GNOME on same machine with same launching commands.

Additional info:
See attached crash report output by Minecraft launcher.
Comment 1 Deepak Bhole 2015-12-02 16:22:38 EST
Not sure where the issue lies here. Assigning to Mario to take a look.
Comment 2 Kamil Páral 2015-12-03 04:05:53 EST
This is probably related to the fact that you can't set display resolution under Wayland (yet), but you need to ask Wayland developers for detailed info.
Comment 3 Michael Wiktowy 2015-12-08 15:23:54 EST
I am not 100% convinced that this is the same resolution switching issue as other games are having.

The reason being is that I am running Minecraft in a "windowed" mode and not as "full screen" (no typical screen flicker as the whole video mode is changed, like in other games where you lose the window decorations).

I run Minecraft, it opens in a small window and then I drag the title bar up to the top to make it "full screen", but in reality it is just maximized. All the other apps are just hidden behind and fully accessible when the Minecraft window releases the mouse (esc or opening inventory, etc) and the Minecraft window still has the GNOME window frame around it.

Perhaps, under Wayland, Minecraft needs the *ability* to go into full-screen mode just to run in any mode but it might be some other issue in the lwjgl library. I just wanted to point out that difference in light of this bug getting grouped with others in bug 1289714
Comment 4 Kamil Páral 2015-12-09 03:18:09 EST
The traceback says:

Caused by: org.lwjgl.LWJGLException: No modes available
	at org.lwjgl.opengl.LinuxDisplay.init(LinuxDisplay.java:740)
	at org.lwjgl.opengl.Display.<clinit>(Display.java:138)

which seems to indicate it could be closely related to the fact that under XWayland you see only a single resolution (should not be zero, though), and you're not able to set one. So it sounds related, but yeah, can be a different issue as well. I used Minecraft example in bug 1289714, because I haven't seen any other games crash right away under Wayland because of this, even though I suspect there will be some. If this bug turns out to have a different cause, no harm done, it was just listed as an example.
Comment 5 Olivier Fourdan 2015-12-16 09:00:58 EST
I already investigated that one a few months ago, this is a dupe of bug 1236389 that we cannot fix because it's a bug in the underlying, embedded and deprecated lwjgl-2.x shipping with Minecraft which cannot parse the output of xrandr when there is just one single resolution available.

We cannot fix this one unfortunately, this needs to be addressed in lwjgl which is embedded in Minecraft jar file.

*** This bug has been marked as a duplicate of bug 1236389 ***

Note You need to log in before you can comment on or make changes to this bug.