Bug 1287879 - glusterfs does not allow passing standard SElinux mount options to fuse
glusterfs does not allow passing standard SElinux mount options to fuse
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
3.5.4
x86_64 All
high Severity high
: ---
: ---
Assigned To: bugs@gluster.org
: SELinux, Triaged
Depends On: 1287763
Blocks: glusterfs-3.5.7
  Show dependency treegraph
 
Reported: 2015-12-02 17:13 EST by Niels de Vos
Modified: 2015-12-03 06:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1287763
Environment:
Last Closed: 2015-12-03 06:43:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2015-12-02 17:13:42 EST
+++ This bug was initially created as a clone of Bug #1287763 +++
+++                                                           +++
+++ Use this bug to provice a backport to release-3.5         +++

Description of problem:

With older versions of gluster, say 3.5.3, glusterfs supports setting selinux context over fuse.glusterfs mountpoint. After 3.6.1, it throws an error : "Invalid option: context". 

The problem is because of a change in mount.glusterfs script. With older versions, it works fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always in versions from 3.6

Steps to Reproduce:
http://www.gluster.org/pipermail/gluster-users.old/2015-January/020014.html

Actual results:
It throws an error "Invalid option: context"

Expected results:
Inform FUSE that the glusterfs sub-filesystem supports SElinux while passing mount options and allow to set selinux context over the mountpoint.


Additional info:

When you set selinux context, the same can be verfied in /proc/mounts:

vm1:sel /qwe1 fuse.glusterfs rw,context=system_u:object_r:user_home_t:s0,relatime,user_id=0,group_id=0,default_    permissions,allow_other,max_read=131072 0 0

--- Additional comment from Vijay Bellur on 2015-12-02 21:56:01 CET ---

REVIEW: http://review.gluster.org/12858 (fuse: pass default SElinux mount options on to the kernel) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 1 Manikandan 2015-12-03 06:43:47 EST
glusterfs was allowing to pass standard SElinux mount options to fuse before 3.6 version. Since the selinux changes made to 3.6 were not backported to 3.5, closing the bug.

Note You need to log in before you can comment on or make changes to this bug.