Bug 1287923 - GDM problem Oh No Something has gone wrong
GDM problem Oh No Something has gone wrong
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
23
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 20:14 EST by Brian Kaye
Modified: 2016-12-20 11:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 11:36:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Kaye 2015-12-02 20:14:00 EST
Description of problem: "Oh No Something has gone wrong" message after attempting to logon to new installation of Fedora 23 Workstation


Version-Release number of selected component (if applicable):
Fedora 23

How reproducible:
Every time but can be bypassed by using KDE instead of GNOME.

Steps to Reproduce:
1. Install Fedora 23 workstation (network install)
2. Boot 
3. Attempt to logon

Actual results:

Get message "Oh No Something has gone wrong" 

Expected results: Be  able to logon.


Additional info:
New install after a disk failure after 12 years since I bought the machine. I really wanted KDE. I did try the KDE spin but had problems there too with a white screen. So I installed Fedora 23 Workstation (Network install). Upon reboot when the install was done and I attempted to logon I got the "Oh No....." message. The logon screen sort of looked like Gnome but I am not sure since I use KDE on all my machines. 

Machine is an IBM Intellistation (Model 6229-33u) with an Nvidia Quadro4 200NVS. Was running Fedora 20 prior to the disk crash. 

My next steps were to switch to another console (Alt ctrl F3) and logon. I changed the system away from the graphical logon and tried "Startx" after a reboot. I got the same error message.

I installed the rest of the KDE packages, did a switchdesk to use KDE and after a reboot and a "startx" I was able to get back to a usable system. However I cannot boot into graphical mode.
Comment 1 Brian Kaye 2015-12-02 21:55:13 EST
The behavior is slightly different when booting to graphical mode. I can attempt to logon before its gives me the "Oh no! ..." message.  The full text of the message is: "Oh no! Something has gone wrong. A problem has occurred and the system cannot recover. All extensions have been disabled as a precaution" 

Sounds like a windows3 message :-)

When I get the message from non graphical mode I am already logged on. There are no error messages on the console
Comment 2 Brian Kaye 2015-12-03 11:24:08 EST
Did a complete reinstall of Fedora 23 Workstation (network install) including a reformat of the root partition and removing the disk with the home partition. The only packages I added were the Editors and System Management. 

Upon reboot I got the "Oh! no" message. I clicked on the logout  and was given the "Welcome" which made me create a user with a good password (it would not let me continue otherwise). I got to the Logon screen where this new user was displayed. I entered the password (took two attempts even though I was very careful) and then got the "Oh no!" screen again. Pressed Logout and looped back to the logon. I tried to logon with root with the same result
Comment 3 Brian Kaye 2015-12-03 16:29:19 EST
More testing. 
   1. Installed KDE packages group (GNOME still there), switchdesk.
   2. systemctl set-default multi-user
   3. boot, login as root, startx, got "Oh! no" message, logout to terminal
   4. switchdesk kde, startx, connected to KDE desktop, things worked
   5. systemctl set-default graphical
   6. boot to gdm(?) logon screen
   7. logon as root, got "Oh! no" message. It then dropped into a welcome screen that first wanted to Language, then the keyboard, then Privacy settings, then connect online accounts (which I skipped),then got a Ready to Go. Then I clicked on "Start Using Fedora" after which I got a window  which had several choices (Getting Started, switch tasks,Respond to messages)  I think this is a Gnome help window. Closed the help window and got back to the "Oh! no" screen and from there to the logon screen again.
   8. At another terminal (Alt Ctrl-F2) systemctl disable gdm; systemctl enable kdm
   9. boot  (still in graphical mode), got the kdm logon screen and was able to logon as root and do something useful. 

So looks like the problem is gdm or something connected to it.
Comment 4 Brian Kaye 2015-12-05 17:54:36 EST
could login KDE desktop only as root. Removed as much of gnome as I could find and did a switchdesk to kde. I can at least logon
Comment 5 Brian Kaye 2015-12-06 23:52:44 EST
Thinking the problem was solved I connected my old /home directory and my account. I did all the testing above as root. It still works as root but not as an ordinary user even with KDE. Maybe its another problem that gives the same error message. That's part of the problem with generic error messages.

Logged on a terminal as a normal user and did a switchdesk kde. All appears to be working using kdm as the window manager. Using sddm however results in a white window but that is another problem.
Comment 6 John Gotts 2015-12-07 20:07:30 EST
I'm having the same problem with gdm.

The system was working fine with Fedora 22. I updated to 23. gdm now appears to log me in. The screen looks correct but the moment I touch the mouse or keyboard, gdm gives me that generic error and kicks me back out to the login prompt. I can do nothing.

Turning off runlevel 5 or whatever the systemd equivalent is and using startx works fine, so clearly there is a problem with gdm.
Comment 7 Brian Kaye 2015-12-07 23:07:28 EST
I got rid of gdm since I wanted to use kde. Tried so many things that I was unsure of the status of my machine so I went back an installed a new Fedora 23 from the KDE spin. Boots to a white screen with a cursor. If word of this gets out we may be teased about the WSOD from the windows community.

See if you have sddm running  (ps aux |grep -e sddm -e gdm -e kdm)

(systemctl status sddm kdm gdm)   will list the various display manager statuses and show some journal entries.


I installed system-switch-displaymanager which was useful in switching between kdm and sddm.
Comment 8 John Gotts 2015-12-12 00:50:36 EST
I found the problem.

For many years, my

/etc/X11/xorg.conf.d/00-keyboard.conf

was corrupt. system-setup-keyboard generated a bad one who knows how long ago. It isn't even called system-setup-keyboard anymore.

Whatever version of X comes with Fedora 23 was the first version to be sensitive to a bad 00-keyboard.conf. I've been running Fedora on this particular computer since Fedora Core 1.

First, check 00-keyboard.conf. It may be bad, but perhaps non-obviously. Re-run

system-config-keyboard

and completely restart gdm. It might be best to reboot.

I bet this will fix many people's Oh no!'s. No guarantee that it will fix all of them, though!
Comment 9 John Gotts 2015-12-12 01:19:35 EST
That didn't really fix it.

Here's what appears to be going on.

gdm-x-session does something that it should not be doing, and partially but not completely crashes with the Oh no! error.

Meanwhile, another gdm-x-session starts and you can log in with this one.

Humorously, I'm now logged in properly with one gnome-session on terminal 6 and the login prompt is still present on terminal 1.

When I log out of the session that worked, it appears that two different login prompts are running on top of each other on terminal 1.

Session that crashed but is still running:

gdm       1697  0.0  0.3  48236  9704 tty1     Ssl+ 01:03   0:00 /usr/libexec/gdm-x-session /usr/bin/gnome-session --autostart /usr/share/gdm/greeter/autostart

Session that is working:

jgotts    3139  0.0  0.3  48236  9752 tty7     Ssl+ 01:06   0:00 /usr/libexec/gdm-x-session --run-script env GNOME_SHELL_SESSION_MODE=classic gnome-session --session gnome-classic

This is not how gdm is supposed to work, is it?

By the way, the only error I was able to find by using the systemd tool is the Cogl-ERROR out of memory error. That appears to be what is crashing gnome-session. Any idea what this is or how to disable it?
Comment 10 Fedora End Of Life 2016-11-24 08:56:32 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 11 Fedora End Of Life 2016-12-20 11:36:00 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.