This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1287944 - Repetition of available objects when executing oc client
Repetition of available objects when executing oc client
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Fabiano Franz
Xingxing Xia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 00:23 EST by Salim Badakhchani
Modified: 2017-03-08 13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-27 05:34:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Salim Badakhchani 2015-12-03 00:23:28 EST
Description of problem:

When you execute the oc client with the "get" option and don't provide a resource the client correctly prints out all the resources that are available.  It seem however to print out the resource "* replicationcontrollers (aka 'rc')"
twice!

Version-Release number of selected component (if applicable):

3.1

How reproducible:

Always

Steps to Reproduce:
1. oc get
2.
3.

Actual results:

You must specify the type of resource to get. Valid resource types include:
   * pods (aka 'po')
   * replicationcontrollers (aka 'rc')
   * daemonsets (aka 'ds')
   * services (aka 'svc')
   * deploymentconfigs (aka 'dc')
   * buildconfigs (aka 'bc')
   * builds
   * routes
   * replicationcontrollers (aka 'rc')
   * events (aka 'ev')
   * projects
   * secrets
   * imagestreams (aka 'is')
   * imagestreamtags (aka 'istag')
   * imagestreamimages (aka 'isimage')
   * persistentvolumes (aka 'pv')
   * persistentvolumeclaims (aka 'pvc')
   * policies
   * rolebindings
   * limitranges (aka 'limits')
   * resourcequotas (aka 'quota')
   * nodes (aka 'no')
   * namespaces (aka 'ns')
   * users
   * groups
   * componentstatuses (aka 'cs')
   * endpoints (aka 'ep')
error: Required resource not specified.
See 'oc get -h' for help and examples.

Expected results:


You must specify the type of resource to get. Valid resource types include:
   * pods (aka 'po')
   * replicationcontrollers (aka 'rc')
   * daemonsets (aka 'ds')
   * services (aka 'svc')
   * deploymentconfigs (aka 'dc')
   * buildconfigs (aka 'bc')
   * builds
   * routes
   * events (aka 'ev')
   * projects
   * secrets
   * imagestreams (aka 'is')
   * imagestreamtags (aka 'istag')
   * imagestreamimages (aka 'isimage')
   * persistentvolumes (aka 'pv')
   * persistentvolumeclaims (aka 'pvc')
   * policies
   * rolebindings
   * limitranges (aka 'limits')
   * resourcequotas (aka 'quota')
   * nodes (aka 'no')
   * namespaces (aka 'ns')
   * users
   * groups
   * componentstatuses (aka 'cs')
   * endpoints (aka 'ep')
error: Required resource not specified.
See 'oc get -h' for help and examples.
Additional info:
Comment 2 Fabiano Franz 2016-07-04 22:51:18 EDT
Fixed in master. Resources are also now sorted.
Comment 3 Xingxing Xia 2016-07-07 01:08:50 EDT
Verified in oc v3.3.0.2. Unique and sorted.
$ oc get
You must specify the type of resource to get. Valid resource types include:
   * buildconfigs (aka 'bc')
   * builds
   * componentstatuses (aka 'cs')
   * configmaps
   * daemonsets (aka 'ds')
   * deploymentconfigs (aka 'dc')
   * deployments
   * events (aka 'ev')
   * endpoints (aka 'ep')
   * horizontalpodautoscalers (aka 'hpa')
   * imagestreamimages (aka 'isimage')
   * imagestreams (aka 'is')
   * imagestreamtags (aka 'istag')
   * ingress (aka 'ing')
   * groups
   * jobs
   * limitranges (aka 'limits')
   * nodes (aka 'no')
   * namespaces (aka 'ns')
   * pods (aka 'po')
   * persistentvolumes (aka 'pv')
   * persistentvolumeclaims (aka 'pvc')
   * policies
   * projects
   * quota
   * resourcequotas (aka 'quota')
   * replicasets (aka 'rs')
   * replicationcontrollers (aka 'rc')
   * rolebindings
   * routes
   * secrets
   * serviceaccounts (aka 'sa')
   * services (aka 'svc')
   * users
error: Required resource not specified.
See 'oc get -h' for help and examples.
Comment 5 errata-xmlrpc 2016-09-27 05:34:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933

Note You need to log in before you can comment on or make changes to this bug.