Bug 1287962 - Discovery does not warn if subnet does not have tftp proxy configured when provisioning a host
Discovery does not warn if subnet does not have tftp proxy configured when pr...
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 02:18 EST by Justin Sherrill
Modified: 2017-05-24 04:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-24 04:37:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12705 None None None 2016-04-22 11:37 EDT

  None (edit)
Description Justin Sherrill 2015-12-03 02:18:06 EST
Description of problem:

When provisioning a host with discovery if the host's subnet does not have a tftp proxy configured the discovered host will reboot and go back into the discovery mode.  Foreman should be able to recognize this situation and at least warn the user that this is not configured.  

I'm not positive if there is even a use case for the tftp proxy to not be associated to the subnet in this sceanrio, so we may want to block the discovery provisioning attempt if not.

At least one customer has hit this.


Version-Release number of selected component (if applicable):
6.1.4

How reproducible:
Always

Steps to Reproduce:
1.  Configure pxe discovery but do not associate the subnet with a tftp proxy/capsule
2. boot a system on that subnet
3. attempt to provision it

Actual results:
System reboots and goes back into discover

Expected results:
At least a warning is given to inform the user the tftp proxy is not configured on the subnet.


Additional info:
Comment 1 Bryan Kearney 2015-12-04 11:52:26 EST
Created redmine issue http://projects.theforeman.org/issues/12705 from this bug
Comment 3 Lukas Zapletal 2015-12-07 04:32:01 EST
Well, if you don't have TFTP set, no provisioning will be orchestrated. That has nothing to do with Discovery :-)

I am unlikely to give this a priority as plugins are not able to do stuff like UI warnings without Deface gem. But I could issue a Flash warning message during provisioning, this will only work with one host provisioning tho. If you can help me reviewing and testing the patch, let me know.
Comment 4 Bryan Kearney 2016-02-29 12:11:34 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/12705 has been closed
Comment 5 Lukas Zapletal 2016-03-01 10:01:02 EST
Upstream bug was mis-closed.
Comment 6 Lukas Zapletal 2017-05-24 04:37:14 EDT
Guys, this is trivial thing that does not need to be tracked here, we have an upstream issue, I am unlikely to work on that soon.

Note You need to log in before you can comment on or make changes to this bug.