Bug 1287977 - Incorrect check output from atomic-openshift-installer when working with preconfigured load balancer
Incorrect check output from atomic-openshift-installer when working with prec...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Munilla
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 03:22 EST by Gaoyun Pei
Modified: 2016-07-03 20:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: openshift-ansible-3.0.17-1.git.0.056309b.el7aos
Doc Type: Bug Fix
Doc Text:
atomic-openshift-installer previously generated an unattended installation file which was unusable when the admin provided a pre-configured load balancer. This error has been corrected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 16:19:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2015-12-03 03:22:43 EST
Description of problem:
Perform an HA installation using atomic-openshift-installer with a preconfigured haproxy server, the proxy host wouldn't have ip and public_ip facts in installer.cfg.yml, which would lead to an error when rerun installer unattended.

In ~/.config/openshift/installer.cfg.yml:
...
- connect_to: openshift-143.xxx.xxx.com
  hostname: openshift-143.xxx.xxx.com
  master_lb: true
  preconfigured: true
  public_hostname: openshift-143.xxx.xxx.com


Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.0.16-1.git.61.2054960.el7aos.noarch

How reproducible:
Always

Steps to Reproduce:
1.[root@openshift-v3 ~]# atomic-openshift-installer install
(Input 3 masters, 2 nodes, 1 lb which is pre-configured)
*** Installation Summary ***

Hosts:
- 192.168.0.100
  - OpenShift Master
  - OpenShift Node (Unscheduled)
  - Etcd Member
- 192.168.0.101
  - OpenShift Master
  - OpenShift Node (Unscheduled)
  - Etcd Member
- 192.168.0.102
  - OpenShift Node (Dedicated)
- 192.168.0.103
  - OpenShift Node (Dedicated)
- 192.168.0.104
  - OpenShift Master
  - OpenShift Node (Unscheduled)
  - Etcd Member
- openshift-143.xxx.xxx.com
  - Load Balancer (Preconfigured)

...

Do the above facts look correct? [y/N]: N

Edit /root/.config/openshift/installer.cfg.yml with the desired values and run `atomic-openshift-installer --unattended install` to restart the install.

2.[root@openshift-v3 ~]# atomic-openshift-installer --unattended install


Actual results:
[root@openshift-v3 ~]# atomic-openshift-installer --unattended install
For unattended installs, facts must be provided for all masters/nodes:
Host "openshift-143.xxx.xxx.com" missing facts: ip, public_ip


Expected results:
Installer shouldn't check the preconfigured lb or the preconfigured lb should also have ip and public_ip facts written in installer.cfg.yml 

Additional info:
Comment 2 Gaoyun Pei 2015-12-09 00:52:56 EST
Verify this bug with atomic-openshift-utils-3.0.18-1.git.0.a3e601b.el7aos.noarch.

When rerun installer against a preconfigured haproxy server, it wouldn't break again.
Comment 4 errata-xmlrpc 2015-12-17 16:19:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2667

Note You need to log in before you can comment on or make changes to this bug.