Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1287985 - Add qpid-stat -q/-u to foreman-debug
Summary: Add qpid-stat -q/-u to foreman-debug
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Packaging
Version: 6.1.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-03 08:53 UTC by Pavel Moravec
Modified: 2019-09-26 14:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:00:07 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 12678 0 None None None 2016-04-22 16:56:31 UTC
Red Hat Product Errata RHBA-2016:1500 0 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Pavel Moravec 2015-12-03 08:53:43 UTC
Description of problem:
When investigating pulp or gofer issues, it is often valuable to know qpid broker queue statistics - ideally both queue stats and also subscription stats (to see if some consumer acquired messages and got stuck).

That means, add:

qpid-stat --ssl-certificate=/etc/pki/katello/qpid_client_striped.crt -b amqps://localhost:5671 -q

qpid-stat --ssl-certificate=/etc/pki/katello/qpid_client_striped.crt -b amqps://localhost:5671 -u

to foreman-debug commands to collect, both on Sat and Caps


Version-Release number of selected component (if applicable):
foreman-debug-1.7.2.46-1.el7sat.noarch


How reproducible:
100%


Steps to Reproduce:
1. take foreman-debug
2. find qpid-stat -q / qpid-stat -u output there


Actual results:
No such output


Expected results:
To collect that output


Additional info:

Comment 2 Bryan Kearney 2015-12-03 11:00:44 UTC
Upstream bug component is Content Management

Comment 3 Bryan Kearney 2015-12-21 15:00:38 UTC
Upstream bug component is Packaging

Comment 4 Bryan Kearney 2015-12-22 17:00:41 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12678 has been closed
-------------
Pavel Moravec
As I understood, katello related stuff in foreman-debug should be placed to katello-debug.sh script. Since I am unable to find the script on github, posting the patch here:


--- /usr/share/katello/script/katello-debug.sh	2015-12-03 10:42:38.701491316 +0100
+++ /usr/share/katello/script/katello-debug.sh.new	2015-12-03 10:42:33.566497422 +0100
@@ -56,6 +56,8 @@ if [ $NOGENERIC -eq 0 ]; then
   add_files /etc/qpid/*
   add_files /etc/qpidd.conf
 fi
+add_cmd "qpid-stat --ssl-certificate=/etc/pki/katello/qpid_client_striped.crt -b amqps://localhost:5671 -q" "qpid_stat_queues"
+add_cmd "qpid-stat --ssl-certificate=/etc/pki/katello/qpid_client_striped.crt -b amqps://localhost:5671 -u" "qpid_stat_subscriptions"
 
 # Gofer
 add_files /etc/gofer

Comment 7 Kedar Bidarkar 2016-04-12 09:32:07 UTC
We now have these 2 files in the foreman-debug.

foreman-debug-a2yvh]# ll qpid_stat_*
-rw-r--r--. 1 root root 13257 Apr 12 05:28 qpid_stat_queues
-rw-r--r--. 1 root root 17382 Apr 12 05:28 qpid_stat_subscriptions

VERIFIED withy sat62-snap7

Comment 9 errata-xmlrpc 2016-07-27 09:00:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.