Bug 1287989 - Login as different user on a finished deployment does not enable any options
Login as different user on a finished deployment does not enable any options
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: TP2
: 1.0
Assigned To: jmagen@redhat.com
Dave Johnson
: Triaged
Depends On:
Blocks: rhci-sprint-12
  Show dependency treegraph
 
Reported: 2015-12-03 04:06 EST by Antonin Pagac
Modified: 2016-10-03 15:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 15:14:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2015-12-03 04:06:44 EST
Description of problem:
When editing a finished deployment, I'm presented with the option to log out and then log into a different account. This works, but does not enable me to do any changes with the subscriptions, I can still only see the previously chosen Subscription Management Application, which is confusing, since it is only on the previous account and not on the currently logged-in one.
Maybe the option to log in as a different user should be disabled for finished deployments?

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20151201.t.0-RHCI-x86_64-dvd1.iso

How reproducible:
Always

Steps to Reproduce:
1. Do a complete successful deployment
2. On the Deployments page, choose to edit your deployment
3. Go to Subscription section, choose "You may logout and then login as a different user."
4. Log in as a different user
5. No options are enabled, no changes in the Subscriptions section can be made

Actual results:
Can log in as a different user but no other changes can be made

Expected results:
I should either be not allowed to log in as a different user, or this action should enable me to do some changes with the subscriptions

Additional info:
Comment 1 John Matthews 2015-12-03 10:41:39 EST
Agree, when editing a deployment that has finished, it doesn't make sense to allow changing the subscription management assets.  

Is there any reason why we would allow editing anything in a finished deployment?  Seems like this should be disabled.
Comment 2 jmagen@redhat.com 2015-12-16 07:51:10 EST
fixed
https://github.com/fusor/fusor/pull/570
Comment 3 Antonin Pagac 2016-01-25 08:42:42 EST
I can still see the login form, but for finished deployment it is grayed-out. Marking as verified.

TP2 RC3
RHCI-6.0-RHEL-7-20160122.t.1-RHCI-x86_64-dvd1.iso

Note You need to log in before you can comment on or make changes to this bug.