Bug 1287994 - Failed to hot set memory to VM. Underlying error message: unsupported configuration: unknown device type 'memory'
Failed to hot set memory to VM. Underlying error message: unsupported configu...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Packaging.rpm (Show other bugs)
4.17.11
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Yaniv Bronhaim
Aharon Canan
virt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 04:24 EST by Sandro Bonazzola
Modified: 2016-02-18 05:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: libvirt requirements not available in CentOS 7.1 and missing updated requirement in VDSM spec file Consequence: memory hotplug feature is not working Workaround (if any): use CR repo until CentOS 7.2 is out, then update to CentOS 7.2 Result: memory hotplug feature should work
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-15 06:15:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: planning_ack?
sbonazzo: devel_ack?
sbonazzo: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Sandro Bonazzola 2015-12-03 04:24:59 EST
Description of problem:
Tried to expand memory from 2GB to 4GB on my VM, engine shows:
Failed to hot set memory to VM satellite. Underlying error message: unsupported configuration: unknown device type 'memory'

Version-Release number of selected component (if applicable):
Both engine and host are updated to oVirt 3.6.1 RC2 on CentOS 7.1

How reproducible:
100%

Steps to Reproduce:
1. create a VM with 2 GB of ram
2. boot it
3. hotplug other 2 GB of ram

Actual results:
It fails to hotplug ram


Expected results:
It should work

Additional info:
I still have the environment up, ping me in IRC if you want to inspect
Comment 3 Michal Skrivanek 2015-12-04 05:17:08 EST
you may be running wrong qemu (do you have qemu-kvm-ev 2.3+?) or wrong cluster level...
Where/whenhow did you create that VM?
Comment 4 Sandro Bonazzola 2015-12-09 16:24:41 EST
qemu was right, looking at users mailing list it seems to be a libvirt version issue.
We should enforce minimum version in vdsm spec file in order to avoid this kind of issues.
Comment 5 Yaniv Kaul 2016-01-10 08:51:37 EST
(In reply to Sandro Bonazzola from comment #4)
> qemu was right, looking at users mailing list it seems to be a libvirt
> version issue.
> We should enforce minimum version in vdsm spec file in order to avoid this
> kind of issues.

- Which libvirt version do we need?
- Perhaps worth changing the bug title to 'depend on libvirt version ...'
Comment 6 Michal Skrivanek 2016-01-15 06:15:35 EST
since 3.6.1 we require RHEL/CentOS 7.2, so I don't think we need to do anything anymore
Comment 7 Sandro Bonazzola 2016-02-18 05:50:50 EST
Re-rested yesterday on my local lab with CentOS 7.2, now worked.

Note You need to log in before you can comment on or make changes to this bug.