Bug 1288029 - Please add systemd-libs requirement
Please add systemd-libs requirement
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pyudev (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 05:49 EST by Jaroslav Škarvada
Modified: 2015-12-07 15:27 EST (History)
3 users (show)

See Also:
Fixed In Version: python-pyudev-0.17-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 15:27:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2015-12-03 05:49:18 EST
Description of problem:
This is python binding for libudev, so it should have requirement on libudev, which is provided by systemd-libs

Version-Release number of selected component (if applicable):
python-pyudev-0.17-3.fc24

How reproducible:
Always

Steps to Reproduce:
1. rpm -q --requires python2-pyudev

Actual results:
No libudev dependency

Expected results:
libudev dependency

Additional info:
This is same for python-pyudev/python3-pyudev. This is python, so the correct runtime dependecies aro not automatically picked by RPM.

Just adding:
Requires: systemd-libs
should be enough.

Systemd-libs should be installed in most cases, but we shouldn't rely on it. There is RHEL bug, where anaconda crashed because this dependency is not satisfied during the install time, so we may also encounter this problem sooner or later in Fedora.
Comment 1 David Shea 2015-12-03 13:11:45 EST
Will do. I'm also going to move the GUI toolkit integration modules (glib, pyqt4, etc) into separate packages and add the dependencies for those. I'll get the new packages built once koji decides to actually build anything. Right now it's just kind of sitting there.
Comment 2 Fedora Update System 2015-12-04 09:42:25 EST
python-pyudev-0.17-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6facfea53f
Comment 3 David Shea 2015-12-04 09:43:05 EST
Built for rawhide and F23. If you need other branches, let me know.
Comment 4 Fedora Update System 2015-12-04 11:50:33 EST
python-pyudev-0.17-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-pyudev'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6facfea53f
Comment 5 Fedora Update System 2015-12-07 15:27:17 EST
python-pyudev-0.17-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.