Bug 1288071 - USB redirection | Windows | Issues with usbdk and activex
USB redirection | Windows | Issues with usbdk and activex
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 07:41 EST by Tomas Jamrisko
Modified: 2017-01-02 09:50 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-02 09:50:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2015-12-03 07:41:00 EST
Description of problem:

USB redirection is not working when connecting using browser plugin and having only usbdk installad. 
Client crashes, when both usbdk and usbclerk are installed

Version-Release number of selected component (if applicable):
2.0-112 (rhevm-spice-client 3.6-5)

How reproducible:
100 %

Steps to Reproduce:
1. Install usbdk on a win7 x64 client
2. Try connecting to any VM with USB redirection enabled from rhevm using browser plugin in IE11

Actual results:
USB redirection is greyed out

Expected results:
It should work

Additional info:
It works fine when connecting using .vv file
It also works when using usbclerk instead of usbdk
Comment 1 Uri Lublin 2015-12-20 05:30:36 EST
Both reported issues work for me but with IE9.
I'll update my Windows 7 and try again
Comment 2 Tomas Jamrisko 2016-01-08 07:11:08 EST
Tried reproducing it with -128 and it worked as expected. No idea why it failed previously...
Comment 3 Uri Lublin 2017-01-02 09:50:46 EST
Closing this bug, following comment 1 and comment 2.

Note You need to log in before you can comment on or make changes to this bug.