Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1288079 - GHC 7.10
GHC 7.10
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Petersen
ChangeAcceptedF24, ChangeAcceptedF25,...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 07:52 EST by Jan Kurik
Modified: 2016-11-22 08:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
[from https://fedoraproject.org/wiki/Documentation_Development_Haskell_Beat] The GHC Haskell compiler has been updated from version 7.8.4 to 7.10.3 in Fedora 25. Haskell packages in Fedora have been rebuilt with the new compiler, and many packages updated. Users will need to update and rebuild their own Haskell projects. The latest stable version of GHC provides many improvements and enhancements. For details, refer to the upstream release notes: https://downloads.haskell.org/~ghc/latest/docs/html/users_guide/release-7-10-1.html https://downloads.haskell.org/~ghc/latest/docs/html/users_guide/release-7-10-2.html https://downloads.haskell.org/~ghc/latest/docs/html/users_guide/release-7-10-3.html
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-22 08:58:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
petersen: fedora_requires_release_note?


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-12-03 07:52:10 EST
This is a tracking bug for Change: GHC 7.10
For more details, see: https://fedoraproject.org//wiki/Changes/GHC_7.10

Update Fedora's version of the GHC Haskell compiler to version 7.10.
Comment 1 Jan Kurik 2016-02-24 09:25:53 EST
On 2016-Feb-23, we have reached Fedora 24 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Completion deadline.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo on 2016-Feb-26 meeting.  Contingency plan for System Wide Changes, if planned for Alpha (or in case of serious doubts regarding Change completion), will be activated.
Comment 2 Jens Petersen 2016-02-25 23:25:25 EST
No progress mostly due to lack of package review manpower and time. :(

We're postponing ghc-7.10 until F25.
Comment 3 Jens Petersen 2016-02-25 23:33:16 EST
(For those keen to use ghc-7.10.3 on Fedora you can use my Copr
https://copr.fedorainfracloud.org/coprs/petersen/ghc-7.10.3/ and
may also find https://copr.fedorainfracloud.org/coprs/petersen/stack/ useful.)
Comment 4 Jaroslav Reznik 2016-07-04 07:11:35 EDT
Change was accepted for Fedora 25.
Comment 5 Jens Petersen 2016-07-20 02:09:31 EDT
This work is largely done and testable now in Fedora Rawhide.
Comment 6 Jan Kurik 2016-07-26 00:54:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 7 Jan Kurik 2016-09-29 05:06:02 EDT
On 2016-Sep-27 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 25 release. At this point all the Changes not at least in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan
Comment 8 Jens Petersen 2016-10-02 21:28:23 EDT
This is basically finished - i working on cleaning up the last remaining dependency breakage asap.

Note You need to log in before you can comment on or make changes to this bug.