Bug 1288106 - all euca2ools trigger "Unknown option" python error
all euca2ools trigger "Unknown option" python error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: euca2ools (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Garrett Holmstrom
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 09:39 EST by Daniela
Modified: 2015-12-04 14:21 EST (History)
3 users (show)

See Also:
Fixed In Version: euca2ools-3.3.0-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 14:21:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniela 2015-12-03 09:39:13 EST
Description of problem:
euca2ools trigger "Unknown option" python error


Version-Release number of selected component (if applicable):
3.3.0-0.1.pre1.fc23 

How reproducible:
Always.

Steps to Reproduce:
1. run any euca command


Actual results:

deathstar:gridppcl03 :~] euca-describe-images 
Unknown option: - 
usage: /usr/bin/python [option] ... [-c cmd | -m mod | file | -] [arg] ...
Try `python -h' for more information.


Expected results:
Command runs successfully.

Additional info:
Caused by multiple options in script hashbang.

It looks like this might be fixed in rawhide, would it be possible to backport this ?

Regards,
Daniela
Comment 1 Fedora Update System 2015-12-03 15:26:53 EST
euca2ools-3.3.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-356c64f87c
Comment 2 Fedora Update System 2015-12-04 14:21:03 EST
euca2ools-3.3.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.