Bug 1288118 - [DELL 7.2 BUG] Automatic installation fails with exception when trying to install on sdp.
[DELL 7.2 BUG] Automatic installation fails with exception when trying to ins...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet (Show other bugs)
7.2
x86_64 Linux
high Severity urgent
: rc
: 7.3
Assigned To: David Lehman
Release Test Team
: Patch
Depends On:
Blocks: 1171868 1304407 1364088
  Show dependency treegraph
 
Reported: 2015-12-03 10:05 EST by Sujith
Modified: 2016-11-03 19:52 EDT (History)
9 users (show)

See Also:
Fixed In Version: python-blivet-0.61.15.56-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:52:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (13.05 KB, text/plain)
2015-12-03 10:05 EST, Sujith
no flags Details
storage.log (70.48 KB, text/plain)
2015-12-03 10:05 EST, Sujith
no flags Details
ks.cfg (2.15 KB, text/plain)
2015-12-03 10:06 EST, Sujith
no flags Details

  None (edit)
Description Sujith 2015-12-03 10:05:02 EST
Created attachment 1101825 [details]
anaconda.log

Description of problem:
In a system having 16 disks, an exception aborts the RHEL-7.2 automatic installation when trying to install on the 16th disk i.e sdp.

Version-Release number of selected component (if applicable):
anaconda-21.48.22.56-1
python-blivet-0.61.15.37-1

How reproducible:
Always

Steps to Reproduce:
1. Setup a server with 16 disks in UEFI mode.
2. Start automatic installation using a kickstart which tries to partition/install on sdp
3. Exception is encountered.

Actual results:
Automatic Installation aborts.

Expected results:
Automatic Installation should be successful.

Additional info:
* This is mainly because the control-flow is entering into a wrong code-segment due to an overly inclusive regex controlling the control-flow entry.

It is fixed in blivet with the following patch:
https://github.com/rhinstaller/blivet/commit/5a1c2d62b51e5e0ee752ec782f5db5b6f223a07a

Commit-id: 5a1c2d62b51e5e0ee752ec782f5db5b6f223a07a

Attaching the logs for reference.
Comment 1 Sujith 2015-12-03 10:05 EST
Created attachment 1101826 [details]
storage.log
Comment 2 Sujith 2015-12-03 10:06 EST
Created attachment 1101827 [details]
ks.cfg

Kickstart used for installation
Comment 3 Marek Hruscak 2016-07-15 08:21:07 EDT
I have reproduced it on RHEL-7.2RC on KVM VM with UEFI firmware(ovmf_x64/OVMF_CODE-pure-efi.fd) with 16 disks, where 15 have 100M and 16th(vdp) have 6G. Modify ks.cfg to match disk names and installation size.
Comment 4 Sujith 2016-08-08 09:49:55 EDT
Can still observe the issue with python-blivet-0.61.15.53-1.el7 present in RHEL-7.3-Alpha-1.
Please incorporate the patch mentioned in #Description.

Regards,
Sujith
Comment 8 Jakub Vavra 2016-09-13 04:07:10 EDT
Fix verified on snapshot 3 (RHEL-7.3-20160908.3).
Comment 9 Sujith 2016-09-14 01:04:00 EDT
Snapshot-2 contains python-blivet-0.61.15.55-1.el7
We shall verify once the Snapshot-3 builds are available to us.

-
Sujith
Comment 11 errata-xmlrpc 2016-11-03 19:52:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2168.html

Note You need to log in before you can comment on or make changes to this bug.