Bug 1288131 - Provider event results show hyper link of the provider name which leads to the infrastructure provider which never existed
Provider event results show hyper link of the provider name which leads to th...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.6.0
Assigned To: Mooli Tayer
Dafna Ron
container
:
Depends On:
Blocks: 1289590
  Show dependency treegraph
 
Reported: 2015-12-03 10:54 EST by Dafna Ron
Modified: 2016-06-29 11:16 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289590 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:16:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shots (1.57 MB, application/x-gzip)
2015-12-03 10:54 EST, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2015-12-03 10:54:43 EST
Created attachment 1101840 [details]
screen shots

Description of problem:

in the provider's result, we get a link in the container to the provider in the infrastructure main page. since I never created a provider in the infrastructure page I get a "no longer exist message" and "no records found" message

Version-Release number of selected component (if applicable):

cfme-5.5.0.13-1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. navigate to providers -> select provider -> monitoring -> timeline
2. in the results shown (only power results are shown for now) select one of the containers
3. press the provider link in the pop-up window (which has the same name as your openshift provider)

Actual results:

we are re-directed to the infrastructure page 

Expected results:

we should not be re-directed to the provider page

Additional info: screen shots and logs
Comment 1 Federico Simoncelli 2015-12-03 12:13:57 EST
Mooli, this may be related to the balloon changes introduced in:

https://github.com/ManageIQ/manageiq/pull/5053

for some reason it seems that the provider link is not correctly generated.

Discuss it with Daniel as he is adding the id of the other entities (pods, containers and replicators) and the links generated for those may be wrong as well.
Comment 2 Mooli Tayer 2015-12-08 04:16:41 EST
proposed fix upstream: 
https://github.com/ManageIQ/manageiq/pull/5742
Comment 3 Mooli Tayer 2015-12-13 10:16:09 EST
submitted upstream: https://github.com/ManageIQ/manageiq/pull/5742
Comment 4 Einat Pacifici 2016-04-17 04:51:18 EDT
Verified. When clicking on the provider's name within the container details, the user is redirected to the Containers-->Provider page.
Comment 5 Lucy Bopf 2016-05-17 01:15:38 EDT
It appears that this bug should no longer be documented as a known issue (and the requires_doc_text flag has been set to '-'). Removing doc text as well.
Comment 7 errata-xmlrpc 2016-06-29 11:16:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.