Bug 1288134 - all events appear with the same name (the provider name) in the timeline
all events appear with the same name (the provider name) in the timeline
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
unspecified Severity urgent
: GA
: 5.6.0
Assigned To: Daniel Korn
Dafna Ron
container
:
Depends On:
Blocks: 1289199 1300376
  Show dependency treegraph
 
Reported: 2015-12-03 11:10 EST by Dafna Ron
Modified: 2016-06-29 11:16 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289199 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:16:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and screenshots (1.81 MB, application/x-gzip)
2015-12-03 11:10 EST, Dafna Ron
no flags Details
example from infra provider (123.01 KB, image/png)
2015-12-07 08:14 EST, Daniel Korn
no flags Details
example from infra provider (77.90 KB, image/png)
2015-12-07 08:14 EST, Daniel Korn
no flags Details

  None (edit)
Description Dafna Ron 2015-12-03 11:10:00 EST
Created attachment 1101842 [details]
logs and screenshots

Description of problem:

On the monitorinng ->timeline, all of the containers and pods have the name of the provider instead of their own name. 

Version-Release number of selected component (if applicable):

cfme-5.5.0.13-1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. navigate to provider -> select provider -> monitoring -> timeline 
2. navigate to pods -> select a pod -> monitoring -> timeline
3. navigate to containers -> select a container -> timeline

Actual results:

All of the objects that appear under the timeline have the same name which is the provider. 

Expected results:

we should see the object's actual name 

Additional info: logs and screenshots
Comment 1 Daniel Korn 2015-12-07 08:14 EST
Created attachment 1103220 [details]
example from infra provider
Comment 2 Daniel Korn 2015-12-07 08:14 EST
Created attachment 1103222 [details]
example from infra provider
Comment 3 Daniel Korn 2015-12-07 08:15:55 EST
To maintain consistency with other providers, the event should display the *entity name* and not the provider or event type. see attached screenshots for infra provider.

Though it makes sense to show the event type when the event is directly related to the entity you look at (for example CONTAINER_STARTED when you look at a container), IMHO it is not the right choice when the event is related to an inner entity (container when you look at the pod's timeline).
Comment 4 Daniel Korn 2015-12-07 10:53:00 EST
proposed fix: https://github.com/ManageIQ/manageiq/pull/5731
Comment 6 Einat Pacifici 2016-04-17 04:24:18 EDT
Verified. Created a new container and the container name appears in the timeline view.
Comment 8 errata-xmlrpc 2016-06-29 11:16:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.