Bug 1288168 - The add-registry patch is broken and seems to have repercussions
The add-registry patch is broken and seems to have repercussions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 12:46 EST by David O.
Modified: 2015-12-10 20:50 EST (History)
11 users (show)

See Also:
Fixed In Version: docker-1.9.1-4.git6ec29ef.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 20:50:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David O. 2015-12-03 12:46:44 EST
Description of problem:
There are a number of issues:
* The --add-registry daemon option has no effect anymore.
* Even when it's not specified, a relative docker push to Docker Hub doesn't work.
* And docker build prefixes the resulting image name with a slash (unless you use an absolute URL).

Version-Release number of selected component (if applicable):
docker-1.9.1-2.git78bc3ea.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1. docker push $USER/fedora:23
2. echo 'FROM busybox' | docker build -t test -

Actual results:

1. unable to ping registry endpoint https://$USER/v0/
v2 ping attempt failed with error: Get https://$USER/v2/: dial tcp: lookup $USER: No address associated with hostname
 v1 ping attempt failed with error: Get https://$USER/v1/_ping: dial tcp: lookup $USER: No address associated with hostname

2. docker images | egrep '\btest\b'
/test latest c51f86c28340 4 weeks ago 1.109 MB

Expected results:
-

Additional info:
-
Comment 1 David O. 2015-12-03 13:00:39 EST
A note for the '/' prefix issue:
If you already have a user/name image and try to build with -t user/name then you end up with two images: user/name and /user/name which is really confusing. Running `docker rm user/name` twice deletes both. Building with -t docker.io/user/name works as expected.

Also none of these issues exists in upstream docker - hence me thinking this is rooted in the add-registry patch.
Comment 2 Daniel Walsh 2015-12-03 13:52:53 EST
Is this something that is fixed in docker-1.9.1-3?
Comment 3 Michal Minar 2015-12-04 04:12:25 EST
Yes. Once it's built. It looks like previous two builds failed.
Comment 4 Fedora Update System 2015-12-09 04:31:15 EST
docker-1.9.1-4.git6ec29ef.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-5917f166c6
Comment 5 Fedora Update System 2015-12-09 23:55:28 EST
docker-1.9.1-4.git6ec29ef.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update docker'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-5917f166c6
Comment 6 Fedora Update System 2015-12-10 20:50:15 EST
docker-1.9.1-4.git6ec29ef.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.