Bug 1288181 - Error undefined method `namespace_id' for nil:NilClass in namespace delete.
Error undefined method `namespace_id' for nil:NilClass in namespace delete.
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.2
Assigned To: Harpreet Kataria
Ramesh A
: ZStream
Depends On: 1285036
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 13:57 EST by John Prause
Modified: 2016-02-10 10:21 EST (History)
9 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285036
Environment:
Last Closed: 2016-02-10 10:21:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2015-12-07 13:58:54 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=38be2205f2213fe85225516732647c1503e51e25

commit 38be2205f2213fe85225516732647c1503e51e25
Merge: aa4436a 6a2981f
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Dec 7 13:53:07 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Dec 7 13:53:07 2015 -0500

    Merge branch '55z_pr_5609' into '5.5.z'
    
    Fixed an if condition for namespace/domain button method.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288181
    https://bugzilla.redhat.com/show_bug.cgi?id=1285036
    (cherry picked from commit b8e71ef)
    
    @dclarizi please review/merge, clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/5609
    
    See merge request !579

 app/controllers/miq_ae_class_controller.rb       |  3 +-
 spec/controllers/miq_ae_class_controller_spec.rb | 35 ++++++++++++++++++++++++
 2 files changed, 36 insertions(+), 2 deletions(-)
Comment 5 Ramesh A 2016-01-18 10:35:40 EST
Good to go. Verified and working fine in 5.5.2.1.20160114044944_395c086
Comment 6 errata-xmlrpc 2016-02-10 10:21:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.