Bug 1288203 - dnf is yanking off selinux-policy and selinux-policy-targeted when you remove docker.
dnf is yanking off selinux-policy and selinux-policy-targeted when you remove...
Status: CLOSED DUPLICATE of bug 1259865
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 14:58 EST by Daniel Walsh
Modified: 2015-12-08 09:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 09:37:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2015-12-03 14:58:43 EST
Docker accidentally requires selinux-policy, if you dnf remove docker, dnf will remove not only docker but selinux-policy and selinux-policy-targeted.

Why is dnf doing this?  Is there some way we need to mark selinux-policy to prevent this from happening.  Obviously selinux-policy is a core package on the system and should not be removed.
Comment 1 Michal Luscon 2015-12-08 09:37:27 EST
Unfortunately, this is known bug in PackageKit. "dnf mark install selinux-policy" should help you.

*** This bug has been marked as a duplicate of bug 1259865 ***

Note You need to log in before you can comment on or make changes to this bug.