Bug 1288222 - Memory quota message doesn't display reason [NEEDINFO]
Memory quota message doesn't display reason
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Tina Fitzgerald
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 16:50 EST by Pete Savage
Modified: 2015-12-22 12:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 12:07:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tfitzger: needinfo? (psavage)


Attachments (Terms of Use)

  None (edit)
Description Pete Savage 2015-12-03 16:50:38 EST
Description of problem: When setting up the Red Hat quota for memory and a request is denied, the reason is not displayed.


Version-Release number of selected component (if applicable): 5.5.0.13


How reproducible: 100%


Steps to Reproduce:

ServiceQuota is turned off by default. 

Copy the /Redhat/Service/Provisioning/StateMachines/ServiceProvisionRequestQuotaValidation/ class to a writable domain.

Modify the class schema:
Set manage_quotas to 'true'
Select default quota values for memory. 

Provision the service 2 times, once for passing and once for quota failure.



Actual results: Memory message is not displayed


Expected results: Memory message is displayed


Additional info:
Comment 3 Tina Fitzgerald 2015-12-17 15:03:21 EST
Hi Pete,

This issue is resolved in the new consolidated quota.

Is it okay to close this ticket since this code is deprecated?

Thanks,
Tina
Comment 4 Tina Fitzgerald 2015-12-22 12:07:55 EST
This issue is resolved in the new consolidated quota.

Note You need to log in before you can comment on or make changes to this bug.