Bug 1288256 - %mingw_configure should update config.{guess,sub}
%mingw_configure should update config.{guess,sub}
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mingw-filesystem (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Erik van Pienbroek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7aarch64
  Show dependency treegraph
 
Reported: 2015-12-03 18:54 EST by Yaakov Selkowitz
Modified: 2016-05-26 16:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: mingw-filesystem-101-1.fc24 mingw-filesystem-101-1.fc23 mingw-filesystem-101-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-16 12:25:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for rawhide (1.78 KB, patch)
2015-12-03 19:54 EST, Yaakov Selkowitz
no flags Details | Diff

  None (edit)
Description Yaakov Selkowitz 2015-12-03 18:54:01 EST
In order to avoid needless issues with building software containing old config.{guess,sub} on newer hardware, where this is often the only issue preventing such a build, %configure has been modified to automatically update these in redhat-rpm-config.  %mingw_configure should do the same so that mingw-* builds done on newer hardware (such as aarch64 or ppc64le) will avoid this issue (which does occur with at least mingw-expat).

Please consider this fix for both Fedora and EPEL 7.
Comment 1 Erik van Pienbroek 2015-12-03 19:09:23 EST
I just browsed through the git log of redhat-rpm-config and if I'm correct these are the 2 commits which are relevant to achieve this:
http://pkgs.fedoraproject.org/cgit/redhat-rpm-config.git/commit/?id=2a557175eb20b0a19184095f0787b631278b8e38 (only the last part)
http://pkgs.fedoraproject.org/cgit/redhat-rpm-config.git/commit/?id=43629272a88b1d2c0ea0bd35e28bab0b922ed41a

These two changes look safe enough to me to push to both Fedora and EPEL7.

Is my observation correct that these 2 commits should do the trick?
Comment 2 Yaakov Selkowitz 2015-12-03 19:54 EST
Created attachment 1102016 [details]
Patch for rawhide

(In reply to Erik van Pienbroek from comment #1)
> I just browsed through the git log of redhat-rpm-config and if I'm correct
> these are the 2 commits which are relevant to achieve this:
[snip]
> These two changes look safe enough to me to push to both Fedora and EPEL7.
> 
> Is my observation correct that these 2 commits should do the trick?

Yes, those should do it.  I'm attaching the patch that I'm working with.
Comment 3 Jan Kurik 2016-02-24 09:05:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 D. Marlin 2016-02-24 19:25:43 EST
Since mingw-filesystem-100-3.fc24 resolves this issue, will you please also build this version for EPEL7?
Comment 5 Fedora Update System 2016-05-10 12:59:50 EDT
mingw-filesystem-101-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-31f40ee164
Comment 6 Fedora Update System 2016-05-10 13:00:31 EDT
mingw-filesystem-101-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8bc41add65
Comment 7 Fedora Update System 2016-05-10 13:01:02 EDT
mingw-filesystem-101-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e593ecef49
Comment 8 Fedora Update System 2016-05-12 04:35:43 EDT
mingw-filesystem-101-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e593ecef49
Comment 9 Fedora Update System 2016-05-12 05:35:21 EDT
mingw-filesystem-101-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8bc41add65
Comment 10 Fedora Update System 2016-05-12 05:42:36 EDT
mingw-filesystem-101-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-31f40ee164
Comment 11 Fedora Update System 2016-05-16 12:25:29 EDT
mingw-filesystem-101-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-05-20 19:52:12 EDT
mingw-filesystem-101-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2016-05-26 16:52:32 EDT
mingw-filesystem-101-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.