Bug 1288279 - gnokii needs to be rebuilt for EL7.2
gnokii needs to be rebuilt for EL7.2
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: gnokii (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 20:19 EST by Anssi Johansson
Modified: 2016-01-10 13:52 EST (History)
2 users (show)

See Also:
Fixed In Version: gnokii-0.6.31-12.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-10 13:52:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anssi Johansson 2015-12-03 20:19:41 EST
Description of problem:
gnokii depends on libical.so.0, provided by libical-0.48-6.el7 in RHEL 7.1.

libical was updated in RHEL 7.2, and the updated libical packages provides libical.so.1. This means gnokii will need to be rebuilt against the new library to be usable on RHEL 7.2

Version-Release number of selected component (if applicable):
0.6.31-10.el7

Steps to Reproduce:
1. Upgrade to RHEL 7.2
2. yum install gnokii

Actual results:
See yum complain about a missing dependency

Expected results:
gnokii gets installed

Additional info:
EPEL7's builders have already been updated to RHEL 7.2, so it probably suffices to just bump the release number and rebuild.
Comment 1 Robert Scheck 2015-12-04 05:30:49 EST
I would like to intentionally delay this until GA of CentOS 7.2
Comment 2 Torsten Clauß 2015-12-23 08:03:09 EST
(In reply to Robert Scheck from comment #1)
> I would like to intentionally delay this until GA of CentOS 7.2

CentOS 7.2 is available since 14th of december.
Any chance, that this urgent problem is solved this year.
Comment 3 Fedora Update System 2015-12-23 10:04:16 EST
gnokii-0.6.31-12.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7011eaad42
Comment 4 Fedora Update System 2015-12-26 22:20:53 EST
gnokii-0.6.31-12.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7011eaad42
Comment 5 Fedora Update System 2016-01-10 13:52:47 EST
gnokii-0.6.31-12.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.