Bug 128828 - Bad: "vacation" is missing and users complain
Summary: Bad: "vacation" is missing and users complain
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-30 03:14 UTC by Need Real Name
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 10:37:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2004-07-30 03:14:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Users want to enable a vacation responder to their mail.  For years
they have used the "vacation(1)" program, which is a component of the
sendmail package.  We used to compile and install sendmail on our
Compaq Tru64 Unix systems.  We have made the change to Red Hat
Enterprise Linux 3 and find that this program is not included in the
sendmail package.

I tried to compile and run the "vacation(1)" program from the latest
sendmail source (from sendmail.org).  The program compiled but would
not run properly.  This is double-plus ungood.

Version-Release number of selected component (if applicable):
sendmail-8.12.11-3.3

How reproducible:
Always

Steps to Reproduce:
1. Obtain the sendmail source from sendmail.org
2. compile the code
3. install "vacation(1)"
4. initialize the "vacation(1)" database
5. configure ~/.forward to use "vacation(1)"
6. watch how "vacation(1)" is not used, the "vacation(1)" database is
not updated and look for error messages in /var/log/maillog

Actual Results:  The program does not work.

Expected Results:  I should get an "out of the office" e-mail response
to e-mail sent to the account configured to use "vacation(1)"

Additional info:

Comment 1 Joshua Baker-LePain 2004-08-04 02:11:31 UTC
What happens if you 'ln -s /usr/bin/vacation /etc/smrsh'?  That method
does work with the vacation source from vacation.sourceforge.net. 
But, it *would* be nice if RH compiled vacation into their sendmail
RPM and made it work.

Comment 2 Thomas Woerner 2004-08-31 10:37:28 UTC
No I am sorry, but vacation will not make it into the sendmail package.
Closing as "NOT A BUG".

Comment 3 Michael Hui 2005-08-24 04:03:31 UTC
I also upgraded to Sendmail Version 8.13.4 from the sendmail in Redhat 9. Found
a number of tweak before getting things to work. 

1. I need to add below lines to Site/site.config.m4 to comile SASL with
sendmail. I added the kerberos directory to solve a nmber of errors complaining
"krb5.h" file not found.

dnl ### Changes for SASL
APPENDDEF(`confENVDEF', `-DSASL=2')
APPENDDEF(`conf_sendmail_LIBS', `-lsasl2')
APPENDDEF(`confLIBDIRS', `-L/usr/lib')
APPENDDEF(`confINCDIRS', `-I/usr/include')

APPENDDEF(`confINCDIRS', `-I/usr/kerberos/include')

2. I erase a number of lines in site.m4.config about PH support which generates
error.

3. smrsh bin directory is changed from /etc/smrsh to /usr/adm/sm.bin as default.
I needed to add APPENDDEF(`confENVDEF', `-DSMRSH_CMDDIR=\"/etc/smrsh\"') to
Makefile.m4 of smrsh directory in order to change it back to /etc/smrsh.

4. Finally, the vacation program could work once I su to the user and manually
type "vacation -i". A .vacation.db file is created.

It took me more than a week's work to get all stuff working. Hard work!


Note You need to log in before you can comment on or make changes to this bug.