Bug 1288296 - rubygem-openscap is not compatible with EL 7.2
rubygem-openscap is not compatible with EL 7.2
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: rubygem-openscap (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Šimon Lukašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7aarch64
  Show dependency treegraph
 
Reported: 2015-12-03 21:12 EST by Anssi Johansson
Modified: 2015-12-24 00:06 EST (History)
3 users (show)

See Also:
Fixed In Version: rubygem-openscap-0.4.3-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 00:06:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anssi Johansson 2015-12-03 21:12:32 EST
Description of problem:
rubygem-openscap-0.2.0-2.el7 depends on openscap < 0:1.2.0, but RHEL 7.2 provides openscap = 1.2.5-3.el7. Depending on why rubygem-openscap depends on an old version of openscap, rubygem-openscap may need to updated to be compatible with openscap in RHEL 7.2. At the moment rubygem-openscap is not installable on RHEL 7.2 because of the dependency checks.

Version-Release number of selected component (if applicable):
0.2.0-2.el7

Steps to Reproduce:
1. Upgrade to RHEL 7.2
2. yum install rubygem-openscap

Actual results:
See yum complain about a missing dependency

Expected results:
rubygem-openscap gets installed

Additional info:
EPEL7's builders have already been updated to RHEL 7.2.
Comment 1 Fedora Update System 2015-12-04 10:56:16 EST
rubygem-openscap-0.4.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-e0ab2681f5
Comment 2 Šimon Lukašík 2015-12-04 10:56:55 EST
Thanks for the report Anssi,

I have submitted rubygem-openscap-0.4.3 update to epel7. That will fix the issue.

Nevertheless, you are only experiencing packaging problem. The software will continue to work even with broken dependencies (in this particular case).
Comment 3 Fedora Update System 2015-12-06 03:21:26 EST
rubygem-openscap-0.4.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update rubygem-openscap'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-e0ab2681f5
Comment 4 Fedora Update System 2015-12-24 00:06:38 EST
rubygem-openscap-0.4.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.