Bug 1288309 - mate-panel missing after upgrade on 12/2/2015
mate-panel missing after upgrade on 12/2/2015
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mate-panel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 21:50 EST by jonathan baron
Modified: 2016-04-14 06:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-14 06:13:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
selections from /var/log/messages (96.08 KB, text/plain)
2015-12-05 15:29 EST, jonathan baron
no flags Details
failed attempt to start panel (35.96 KB, text/plain)
2015-12-07 07:10 EST, jonathan baron
no flags Details
successful start of panel in new account (1.95 KB, text/plain)
2015-12-07 07:12 EST, jonathan baron
no flags Details
diff file between dconf dumps before and after problem is fixed (38.06 KB, text/plain)
2015-12-08 12:16 EST, jonathan baron
no flags Details

  None (edit)
Description jonathan baron 2015-12-03 21:50:22 EST
Description of problem:

After upgrade, logout and login, mate panel did not appear. To get it back, I downgraded several packages and rebooted. Several other things I tried did not work.

Version-Release number of selected component (if applicable):

These were the just-upgraded packages I downgraded.

mate-common-1.12.0-1.fc22.noarch
mate-panel-libs-1.12.0-1.fc22.x86_64
mate-panel-1.12.0-1.fc22.x86_64
mate-desktop-1.12.0-1.fc22.x86_64
mate-desktop-libs-1.12.0-1.fc22.x86_64
mate-session-manager-1.12.0-1.fc22.x86_64

I don't know which of these was the offender. But mate-panel was the only thing that did not appear. Unfortunately, it is needed for many things I might have tested but did not test.

I have not tried to reproduce this on another computer. I will do it if someone thinks this is a real bug and wants me to explore further.
Comment 1 Wolfgang Ulbrich 2015-12-04 06:36:19 EST
If those listed packages are upddated is the panel running and just unvisible or did he not started?
Try
'ps aux | grep mate-panel'
And if he's running try 'killall mate-panel' several times to restart the panel.

Mate-1.12 use now gnome-session as session name for dbus, which improved a lot of things in session management, because most apps use gnome-sesion as session name.
This change affects several packages, if one package isn't update something like this can happen.
Can you please check if all packages are updated, mentioned here.
https://bodhi.fedoraproject.org/updates/FEDORA-2015-36f09a80b6
Btw. mate-common package is a developer package which is not from interested here.

I tested the 1.12 update on several box and didn't never run in this issue,
but it is also reported here.
https://bugzilla.redhat.com/show_bug.cgi?id=1287420
The reporter could solve it, but we don't know what causes the issue.
Comment 2 jonathan baron 2015-12-04 10:10:17 EST
The panel was running but not showing.

I tried
killall mate-panel
several times. This does change the PID assigned to mate-panel, but it still does not appear.

Finally I tried
dnf downgrade mate-panel\*
and then
killall mate-panel
again, and it appeared. I have all the packages mentioned in
https://bodhi.fedoraproject.org/updates/FEDORA-2015-36f09a80b6
except mate-netspeed, which is not installed, and of course
mate-panel, which I downgraded. I have also upgraded to 
mate-notification-daemon-1.12.0-2.fc22.x86_64, as of this morning,
but yesterday I was running 1.12.0-1, when the problem started.

I think the reporter "solved" the reported problem by downgrading, right? So I solved my problem too, but this does not seem like a good solution.

Now that I know how to create and fix the bug quickly, I'm willing to run other tests. (The first time it took about an hour to find the right magic, possibly because I did something stupid very early, which prevented me from opening a terminal window while Xorg was running, so I had to do everything from another computer.)

I use the panel pretty heavily. There is lots of stuff in it. I also have 8 workspaces, and switching among them with keys is now so automatic that I don't even know what I do. I've been doing this for 20 years with various window managers, and now Mate seems to be the only one that makes it easy to set up.
Comment 3 jonathan baron 2015-12-05 06:32:00 EST
I installed mate-panel-1.12.0-1, said
killall mate-panel,
and it did not appear. Then I downgraded and again said
killall mate-panel. Then I examined /var/log/messages and looked for the difference between the two attempts to load the panel. The difference was the following lines, which occurred when the panel did not appear.

Dec  5 06:05:15 barber /usr/libexec/gdm-x-session: ** (mate-panel:9788): WARNING **: Could not connect to session manager: Could not get owner of name 'org.mate.SessionManager': no such name
Dec  5 06:05:15 barber /usr/libexec/gdm-x-session: (mate-panel:9788): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Dec  5 06:05:16 barber /usr/libexec/gdm-x-session: ** (mate-panel:9788): WARNING **: Could not connect to session manager: Could not get owner of name 'org.mate.SessionManager': no such name
Dec  5 06:05:16 barber /usr/libexec/gdm-x-session: (mate-panel:9788): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

I also noticed some other thing, but they are not relevant here. I kept getting error messages both times about the terminal applet and the weather applet, but both of these worked fine once the panel appeared. I also had a "shutdown" applet, and this did not work, and I could not find a replacement for it. I made a custom applet for pm-suspend. For reboots and shut downs, I will use the command line. Removing the defunct shutdown applet did not help the main problem.

I also tried the update on another computer, a laptop, and it worked. So this problem is clearly limited to certain configurations.
Comment 4 Wolfgang Ulbrich 2015-12-05 10:10:23 EST
(In reply to jonathan baron from comment #2)
> The panel was running but not showing.
> 
> I tried
> killall mate-panel
> several times. This does change the PID assigned to mate-panel, but it still
> does not appear.
> 
> Finally I tried
> dnf downgrade mate-panel\*
> and then
> killall mate-panel
> again, and it appeared. I have all the packages mentioned in
> https://bodhi.fedoraproject.org/updates/FEDORA-2015-36f09a80b6
> except mate-netspeed, which is not installed, and of course
> mate-panel, which I downgraded. I have also upgraded to 
> mate-notification-daemon-1.12.0-2.fc22.x86_64, as of this morning,
> but yesterday I was running 1.12.0-1, when the problem started.
mate-notification-daemon-1.12.0-1 has a regression, here tha daemon can carash if notification have an image, this is fixed with 1.12.0-2
> 
> I think the reporter "solved" the reported problem by downgrading, right? So
> I solved my problem too, but this does not seem like a good solution.
No, at least he use mate-panel-1.12.0-1, see his postings (6-8).
Hi did some distro-sync and installed it again, but it's not clear what solves the issue.
> 
> Now that I know how to create and fix the bug quickly, I'm willing to run
> other tests. (The first time it took about an hour to find the right magic,
> possibly because I did something stupid very early, which prevented me from
> opening a terminal window while Xorg was running, so I had to do everything
> from another computer.)
Thank you
> 
> I use the panel pretty heavily. There is lots of stuff in it. I also have 8
> workspaces, and switching among them with keys is now so automatic that I
> don't even know what I do. I've been doing this for 20 years with various
> window managers, and now Mate seems to be the only one that makes it easy to
> set up.
Well the panel is one of the basic stuff in MATE, this should work of course.



(In reply to jonathan baron from comment #3)
> I installed mate-panel-1.12.0-1, said
> killall mate-panel,
> and it did not appear. Then I downgraded and again said
> killall mate-panel. Then I examined /var/log/messages and looked for the
> difference between the two attempts to load the panel. The difference was
> the following lines, which occurred when the panel did not appear.
> 
> Dec  5 06:05:15 barber /usr/libexec/gdm-x-session: ** (mate-panel:9788):
> WARNING **: Could not connect to session manager: Could not get owner of
> name 'org.mate.SessionManager': no such name
> Dec  5 06:05:15 barber /usr/libexec/gdm-x-session: (mate-panel:9788):
> GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)'
> failed
> Dec  5 06:05:16 barber /usr/libexec/gdm-x-session: ** (mate-panel:9788):
> WARNING **: Could not connect to session manager: Could not get owner of
> name 'org.mate.SessionManager': no such name
> Dec  5 06:05:16 barber /usr/libexec/gdm-x-session: (mate-panel:9788):
> GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)'
> failed
> 
> I also noticed some other thing, but they are not relevant here. I kept
> getting error messages both times about the terminal applet and the weather
> applet, but both of these worked fine once the panel appeared. I also had a
> "shutdown" applet, and this did not work, and I could not find a replacement
> for it. I made a custom applet for pm-suspend. For reboots and shut downs, I
> will use the command line. Removing the defunct shutdown applet did not help
> the main problem.
> 
> I also tried the update on another computer, a laptop, and it worked. So
> this problem is clearly limited to certain configurations.
Comment 5 Wolfgang Ulbrich 2015-12-05 10:36:35 EST
(In reply to jonathan baron from comment #3)
> I installed mate-panel-1.12.0-1, said
> killall mate-panel,
> and it did not appear. Then I downgraded and again said
> killall mate-panel. Then I examined /var/log/messages and looked for the
> difference between the two attempts to load the panel. The difference was
> the following lines, which occurred when the panel did not appear.
> 
> Dec  5 06:05:15 barber /usr/libexec/gdm-x-session: ** (mate-panel:9788):
> WARNING **: Could not connect to session manager: Could not get owner of
> name 'org.mate.SessionManager': no such name
> Dec  5 06:05:15 barber /usr/libexec/gdm-x-session: (mate-panel:9788):
> GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)'
> failed
> Dec  5 06:05:16 barber /usr/libexec/gdm-x-session: ** (mate-panel:9788):
> WARNING **: Could not connect to session manager: Could not get owner of
> name 'org.mate.SessionManager': no such name
> Dec  5 06:05:16 barber /usr/libexec/gdm-x-session: (mate-panel:9788):
> GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)'
> failed

Well, i guess this log is with downgraded panel, right?
With 1.12 Mate use org.gnome.SessionManager as name, see https://github.com/mate-desktop/mate-session-manager/commit/b01c41715ddad682c2e0d2a5eac8fa0deb91c5e8
In result the downgraded panel search for org.mate.SessionManager but can't find it.
> 
> I also tried the update on another computer, a laptop, and it worked. So
> this problem is clearly limited to certain configurations.

Ok we need more debug output.
Edit /usr/share/xsessions/mate.desktop
Change exec line to
Exec=mate-session --debug
Than you will find the whole session start process in ~.xsession-errors or in journal or /var/log/messages.

Try mate-panel --replace in terminal, maybe you see more infos there.

To be shure that we haven't a config problem, can you create a fresh new account to see if the panel is visible or not.
If the panel is visible here than you can try 'mate-panel --reset' to have a clean default.
But this will delete all customisations, ie. launchers.
Comment 6 Wolfgang Ulbrich 2015-12-05 10:44:18 EST
PS, to be shure we haven't corupte packages in repos, download mate-panel-1.12.1-1 from here and try this one.
http://koji.fedoraproject.org/koji/buildinfo?buildID=703292

It's a bit weird that i get only in f22 reports about this issue but not in f23,
here i did the same update some weeks before and packages are identically.
Comment 7 Wolfgang Ulbrich 2015-12-05 10:49:57 EST
(In reply to Wolfgang Ulbrich from comment #5)
> (In reply to jonathan baron from comment #3)
> > I installed mate-panel-1.12.0-1, said
> > killall mate-panel,
> > and it did not appear. Then I downgraded and again said
> > killall mate-panel. Then I examined /var/log/messages and looked for the
> > difference between the two attempts to load the panel. The difference was
> > the following lines, which occurred when the panel did not appear.
> > 
> > Dec  5 06:05:15 barber /usr/libexec/gdm-x-session: ** (mate-panel:9788):
> > WARNING **: Could not connect to session manager: Could not get owner of
> > name 'org.mate.SessionManager': no such name
> > Dec  5 06:05:15 barber /usr/libexec/gdm-x-session: (mate-panel:9788):
> > GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)'
> > failed
> > Dec  5 06:05:16 barber /usr/libexec/gdm-x-session: ** (mate-panel:9788):
> > WARNING **: Could not connect to session manager: Could not get owner of
> > name 'org.mate.SessionManager': no such name
> > Dec  5 06:05:16 barber /usr/libexec/gdm-x-session: (mate-panel:9788):
> > GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)'
> > failed
> 
> Well, i guess this log is with downgraded panel, right?
> With 1.12 Mate use org.gnome.SessionManager as name, see
> https://github.com/mate-desktop/mate-session-manager/commit/
> b01c41715ddad682c2e0d2a5eac8fa0deb91c5e8
> In result the downgraded panel search for org.mate.SessionManager but can't
> find it.
Opps, i missread your comment, this log is with m-p-1.12.0-1
Weird, this shouldn't happend, because both mate-session-manager and mate-panel use now org.gnome.SessionManager as name for dbus identification.
Comment 8 jonathan baron 2015-12-05 15:29 EST
Created attachment 1102596 [details]
selections from /var/log/messages

I hope this attachment works.
Comment 9 jonathan baron 2015-12-05 15:30:48 EST
> > Well, i guess this log is with downgraded panel, right?
> > With 1.12 Mate use org.gnome.SessionManager as name, see
> > https://github.com/mate-desktop/mate-session-manager/commit/
> > b01c41715ddad682c2e0d2a5eac8fa0deb91c5e8
> > In result the downgraded panel search for org.mate.SessionManager but can't
> > find it.
> Opps, i missread your comment, this log is with m-p-1.12.0-1
> Weird, this shouldn't happend, because both mate-session-manager and
> mate-panel use now org.gnome.SessionManager as name for dbus identification.

Thanks.

In response to your last three comments, I did the following.

1. I got debug output. I will try to attach it. At about 14:05:54 I did
killall mate-panel
with the version that did not work. Then I replaced it with the version that works and did this again at about 14:08.22. Note that even the working version still produces errors. Parts of it won't work, such as the logout button.

2. I did not create a new account. Too hard right now. But did add a second panel with nothing in it. When I switched to the new version, that panel also disappeared. Thus, the problem does not have anything to do with any configuration of the panel itself.[

I suspect that this all has something to do with something I did years ago, but I cannot figure out what. I tried looking for duplicate rpms and did not find any. I do know that, at one point, I tried changing from gdm to something else, but then changed back. And for about 15 years I've been using an
/etc/gdm/autoconf file, which logs me in automatically. (This is my home computer. The laptop is quite different.) And, again for historical reasons, my id number is 501, whereas I think that recent versions of fedora like numbers greater than 1000. The result is that, if I bypass autologin my account is not listed in the greeter. Some of these are things I've been just copying from one machine to another since about 1990.

Still, there are people like me, so it would be nice if we can find the problem.
Comment 10 Wolfgang Ulbrich 2015-12-07 05:03:29 EST
(In reply to jonathan baron from comment #9)
> > > Well, i guess this log is with downgraded panel, right?
> > > With 1.12 Mate use org.gnome.SessionManager as name, see
> > > https://github.com/mate-desktop/mate-session-manager/commit/
> > > b01c41715ddad682c2e0d2a5eac8fa0deb91c5e8
> > > In result the downgraded panel search for org.mate.SessionManager but can't
> > > find it.
> > Opps, i missread your comment, this log is with m-p-1.12.0-1
> > Weird, this shouldn't happend, because both mate-session-manager and
> > mate-panel use now org.gnome.SessionManager as name for dbus identification.
> 
> Thanks.
> 
> In response to your last three comments, I did the following.
> 
> 1. I got debug output. I will try to attach it. At about 14:05:54 I did
> killall mate-panel
> with the version that did not work. Then I replaced it with the version that
> works and did this again at about 14:08.22. Note that even the working
> version still produces errors. Parts of it won't work, such as the logout
> button.
Can you you please attach only a log with mate-panel-1.12.0-1? Install them an restart the system.
> 
> 2. I did not create a new account. Too hard right now. But did add a second
> panel with nothing in it. When I switched to the new version, that panel
> also disappeared. Thus, the problem does not have anything to do with any
> configuration of the panel itself.[
Why is this so hard?
With a fresh account everything is fresh, ie. dconf settings.
For the momment we don't know what causes the issue.
Comment 11 jonathan baron 2015-12-07 07:07:12 EST
> Can you you please attach only a log with mate-panel-1.12.0-1? Install them
> an restart the system.

I will do that in the next response. (I can't figure out how to include attachments here.) It is called messages.
 
> > 2. I did not create a new account. Too hard right now. But did add a second
> > panel with nothing in it. When I switched to the new version, that panel
> > also disappeared. Thus, the problem does not have anything to do with any
> > configuration of the panel itself.[
> Why is this so hard?

Because the logout button doesn't work. I did
killall Xorg
and that worked. It gave me the greeter and I could log into the new account, which I called test.

> With a fresh account everything is fresh, ie. dconf settings.
> For the momment we don't know what causes the issue.

I was able to install two panels with 1.12.0-1. I will try to attach that too (as messages01). So it is clearly something about my configuration.

Thanks for your continued interest.
Comment 12 jonathan baron 2015-12-07 07:10 EST
Created attachment 1103186 [details]
failed attempt to start panel
Comment 13 jonathan baron 2015-12-07 07:12 EST
Created attachment 1103190 [details]
successful start of panel in new account
Comment 14 Wolfgang Ulbrich 2015-12-07 08:10:26 EST
(In reply to jonathan baron from comment #11)
> > > 2. I did not create a new account. Too hard right now. But did add a second
> > > panel with nothing in it. When I switched to the new version, that panel
> > > also disappeared. Thus, the problem does not have anything to do with any
> > > configuration of the panel itself.[
> > Why is this so hard?
> 
> Because the logout button doesn't work. I did
> killall Xorg
> and that worked. It gave me the greeter and I could log into the new
> account, which I called test.

The logout button is part of mate-panel package, with 1.10.x it searched for org.mate.SessionManager, but mate 1.12 use org.gnome.SessionManager now.
For this reason the logout button from mate-panel-1.10.x don't work anymore with mate-session-manager-1.12.x.

Ok, the message
 'WARNING **: Could not connect to session manager: Could not get owner of name 'org.mate.SessionManager': no such name
isn't from 1.12.0-1, what i suspected.

Dec  7 06:31:55 barber org.mate.panel.applet.MateWeatherAppletFactory: (mateweather-applet:16255): MateWeather-CRITICAL **: weather_info_get_icon_name: assertion 'info != NULL' failed
Dec  7 06:31:55 barber org.mate.panel.applet.MateWeatherAppletFactory: (mateweather-applet:16255): MateWeather-CRITICAL **: weather_info_get_temp_summary: assertion 'info != NULL' failed
Dec  7 06:31:55 barber dbus[678]: [system] Activating service name='org.mate.SettingsDaemon.DateTimeMechanism' (using servicehelper)
Dec  7 06:31:55 barber dbus[678]: [system] Successfully activated service 'org.mate.SettingsDaemon.DateTimeMechanism'
Dec  7 06:31:55 barber org.mate.panel.applet.MateWeatherAppletFactory: (mateweather-applet:16255): MateWeather-CRITICAL **: weather_info_get_icon_name: assertion 'info != NULL' failed

Try to remove the weather applet, this applet has an problem to load.
Maybe this causes the issue. All other applets seems to loading fine.
Beside that i see no abnormals.

If this doesn't help, try 'mate-panel --reset'
This will delete your panel customizations.
But honestly, it's easier to add some launchers back to panel as searching for an error somewhere in home dir configs.

If that step doesn't help, next step would be to clean up all dconf settings.
I can give you instructions if you want to do this.
Comment 15 jonathan baron 2015-12-07 12:34:35 EST
(In reply to Wolfgang Ulbrich from comment #14)
> Dec  7 06:31:55 barber org.mate.panel.applet.MateWeatherAppletFactory:
> (mateweather-applet:16255): MateWeather-CRITICAL **:
> weather_info_get_icon_name: assertion 'info != NULL' failed
> Dec  7 06:31:55 barber org.mate.panel.applet.MateWeatherAppletFactory:
> (mateweather-applet:16255): MateWeather-CRITICAL **:
> weather_info_get_temp_summary: assertion 'info != NULL' failed
> Dec  7 06:31:55 barber dbus[678]: [system] Activating service
> name='org.mate.SettingsDaemon.DateTimeMechanism' (using servicehelper)
> Dec  7 06:31:55 barber dbus[678]: [system] Successfully activated service
> 'org.mate.SettingsDaemon.DateTimeMechanism'
> Dec  7 06:31:55 barber org.mate.panel.applet.MateWeatherAppletFactory:
> (mateweather-applet:16255): MateWeather-CRITICAL **:
> weather_info_get_icon_name: assertion 'info != NULL' failed
> 
> Try to remove the weather applet, this applet has an problem to load.
> Maybe this causes the issue. All other applets seems to loading fine.
> Beside that i see no abnormals.

That didn't help.

> If this doesn't help, try 'mate-panel --reset'
> This will delete your panel customizations.
> But honestly, it's easier to add some launchers back to panel as searching
> for an error somewhere in home dir configs.

I had installed a completely new (second) panel, and it didn't work either. So I'm not going to try this.

> If that step doesn't help, next step would be to clean up all dconf settings.
> I can give you instructions if you want to do this.

Maybe I should try that. I could at least write down the ones I had changed. I might have to do this anyway when I upgrade to Fedora 23. So, if isn't too hard, please do. If it is a matter of resetting everything to the default, then I could do that in groups, so that I don't do everything all at once.
I do think I know how to do this. There is a "set to default" button at the bottom of each page in dconf-editor, but maybe that isn't what you mean, and it might be worth trying some things before others.
Comment 16 Wolfgang Ulbrich 2015-12-08 06:54:34 EST
(In reply to jonathan baron from comment #15)
> (In reply to Wolfgang Ulbrich from comment #14)
> > If this doesn't help, try 'mate-panel --reset'
> > This will delete your panel customizations.
> > But honestly, it's easier to add some launchers back to panel as searching
> > for an error somewhere in home dir configs.
> 
> I had installed a completely new (second) panel, and it didn't work either.
> So I'm not going to try this.
Setting up a new panel doesn't clean up general panel settings.
> 
> > If that step doesn't help, next step would be to clean up all dconf settings.
> > I can give you instructions if you want to do this.
> 
> Maybe I should try that. I could at least write down the ones I had changed.
> I might have to do this anyway when I upgrade to Fedora 23. So, if isn't too
> hard, please do. If it is a matter of resetting everything to the default,
> then I could do that in groups, so that I don't do everything all at once.
> I do think I know how to do this. There is a "set to default" button at the
> bottom of each page in dconf-editor, but maybe that isn't what you mean, and
> it might be worth trying some things before others.
For saving you settings use
'dconf dump / > user.txt'
For re-setting all to default use
'dconf reset -f /'
Comment 17 jonathan baron 2015-12-08 09:38:59 EST
Resetting the panel did not help. But resetting dconf did. The problem is gone. Now I have to put back the settings I want. (Just reading in the file I saved is probably just going to cause trouble, and surely I could be just as happy with a lot less configuration.)

Unfortunately, this leaves us without knowing where the problem is, although, if anyone else finds this bug report, at least a fix will be available. If, in the course of fixing dconf, I find what causes the problem, I will report it here. Thus I am not yet closing this bug. I think this will take about a day.

Thanks again for all your help.

Jon
Comment 18 jonathan baron 2015-12-08 12:16 EST
Created attachment 1103654 [details]
diff file between dconf dumps before and after problem is fixed

Just for the record, I am including the results of dconf dump before and after the new panel started working. It appears to me that the main difference is that the old, bad, version had a lot of configuration of gnome. (Indeed, years ago I used gnome, before it became impossible to get the Workplace Switcher working.)
Comment 19 Wolfgang Ulbrich 2015-12-09 08:50:19 EST
See https://github.com/mate-desktop/mate-panel/issues/381
Someone found the culprit.

< [org/mate/marco/general]
< disable-workarounds=true

Setting this to 'true' causes the issue.
I can reproduce it now.
Comment 20 jonathan baron 2015-12-09 12:03:59 EST
(In reply to Wolfgang Ulbrich from comment #19)
> See https://github.com/mate-desktop/mate-panel/issues/381
> Someone found the culprit.
> 
> < [org/mate/marco/general]
> < disable-workarounds=true
> 
> Setting this to 'true' causes the issue.
> I can reproduce it now.

Good. Amazing that someone found this.

Given the instructions for disable-workarounds, this is probably worth fixing. The instructions practically recommend setting it to true. And if someone did that in an old version, they would be where I was. (I vaguely remember that even had a reason for setting this, but it was years ago, and I forgot what that was. Seems to work now with this set to false.)

Note You need to log in before you can comment on or make changes to this bug.