Bug 1288349 - [abrt] audacity: dequeue_pending_request(): audacity killed by SIGABRT
[abrt] audacity: dequeue_pending_request(): audacity killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Timms
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4dd7a9ca0914763b6c193f3cee9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 23:51 EST by Richard Jasmin
Modified: 2016-03-05 17:21 EST (History)
3 users (show)

See Also:
Fixed In Version: audacity-2.1.2-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-05 17:21:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (32.76 KB, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: cgroup (190 bytes, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: core_backtrace (16.53 KB, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: dso_list (15.45 KB, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: environ (2.01 KB, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: maps (85.82 KB, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: mountinfo (3.69 KB, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: open_fds (1.28 KB, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: proc_pid_status (1.01 KB, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details
File: var_log_messages (296 bytes, text/plain)
2015-12-03 23:51 EST, Richard Jasmin
no flags Details

  None (edit)
Description Richard Jasmin 2015-12-03 23:51:14 EST
Description of problem:
according to previous bug, this is the actual crash report:
attempt to record when threshhold not reached. Awaiting pavucontrol to show application is recording from a loopback source. cannot report from non-free because either app is not pluggable as distributed, or at all, however, it should be. problem is not with non-free components.

Version-Release number of selected component:
audacity-2.1.1-1.fc22

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        audacity
crash_function: dequeue_pending_request
executable:     /usr/bin/audacity
global_pid:     1927
kernel:         4.2.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (9 frames)
 #4 dequeue_pending_request at xcb_io.c:177
 #7 gdk_flush at gdkevents-x11.c:2606
 #8 wxStatusBar::SetStatusText at src/generic/statusbr.cpp:157
 #9 ControlToolBar::UpdateStatusBar at toolbars/ControlToolBar.cpp:1133
 #10 ControlToolBar::OnPause at toolbars/ControlToolBar.cpp:1011
 #11 audacityAudioCallback at AudioIO.cpp:4026
 #12 NonAdaptingProcess at src/common/pa_process.c:871
 #13 PaUtil_EndBufferProcessing at src/common/pa_process.c:1562
 #14 CallbackThreadFunc at src/hostapi/alsa/pa_linux_alsa.c:4328
Comment 1 Richard Jasmin 2015-12-03 23:51:18 EST
Created attachment 1102106 [details]
File: backtrace
Comment 2 Richard Jasmin 2015-12-03 23:51:19 EST
Created attachment 1102107 [details]
File: cgroup
Comment 3 Richard Jasmin 2015-12-03 23:51:20 EST
Created attachment 1102108 [details]
File: core_backtrace
Comment 4 Richard Jasmin 2015-12-03 23:51:21 EST
Created attachment 1102109 [details]
File: dso_list
Comment 5 Richard Jasmin 2015-12-03 23:51:22 EST
Created attachment 1102110 [details]
File: environ
Comment 6 Richard Jasmin 2015-12-03 23:51:23 EST
Created attachment 1102111 [details]
File: limits
Comment 7 Richard Jasmin 2015-12-03 23:51:25 EST
Created attachment 1102112 [details]
File: maps
Comment 8 Richard Jasmin 2015-12-03 23:51:26 EST
Created attachment 1102113 [details]
File: mountinfo
Comment 9 Richard Jasmin 2015-12-03 23:51:27 EST
Created attachment 1102114 [details]
File: namespaces
Comment 10 Richard Jasmin 2015-12-03 23:51:28 EST
Created attachment 1102115 [details]
File: open_fds
Comment 11 Richard Jasmin 2015-12-03 23:51:29 EST
Created attachment 1102116 [details]
File: proc_pid_status
Comment 12 Richard Jasmin 2015-12-03 23:51:30 EST
Created attachment 1102117 [details]
File: var_log_messages
Comment 13 David Timms 2015-12-05 00:25:15 EST
I'd like to see if I can reproduce this on my machine. Can you please make a clearer description of the steps taken to get to this crash ?

By the way, it would be worth checking the same against 2.1.2rc1:
dnf --enablerepo=updates-testing install audacity
Comment 14 David Timms 2015-12-05 00:25:31 EST
*** Bug 1251591 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2016-01-01 19:59:35 EST
audacity-2.1.2-0.8.rc2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-558a83f721
Comment 16 Fedora Update System 2016-01-02 07:10:45 EST
audacity-2.1.2-0.8.rc2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-df8c9a2d98
Comment 17 Fedora Update System 2016-01-02 22:21:47 EST
audacity-2.1.2-0.8.rc2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-df8c9a2d98
Comment 18 Fedora Update System 2016-01-02 22:23:08 EST
audacity-2.1.2-0.8.rc2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-558a83f721
Comment 19 Fedora Update System 2016-03-03 14:28:48 EST
audacity-2.1.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee19511560
Comment 20 Fedora Update System 2016-03-04 21:22:56 EST
audacity-2.1.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee19511560
Comment 21 Fedora Update System 2016-03-05 17:21:22 EST
audacity-2.1.2-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.