Bug 1288448 - [DHT]: remove-brick commit happened even thought re-balance failed
[DHT]: remove-brick commit happened even thought re-balance failed
Status: CLOSED DUPLICATE of bug 1258875
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Raghavendra G
Anoop
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 04:19 EST by Byreddy
Modified: 2016-09-17 10:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-24 04:17:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Byreddy 2015-12-04 04:19:00 EST
Description of problem:
=======================
Done the remove-brick when glusterd is down in half of the cluster nodes, rebalance failed with issue "Failed to Fix the Layout" and commit et passed.


Version-Release number of selected component (if applicable):
=============================================================
glusterfs-3.7.5-9


How reproducible:
=================
Always


Steps to Reproduce:
===================
1. Create a distributed-replicate volume ( 2x2, with one brick on each
 server in a 4-server cluster ), start and mount, create data on mount point.
2. Kill glusterd on node1 and node2 ( these hold bricks that form one replica pair )
3. Start remove-brick on the volume ( other two bricks )
4. Check the remove-brick status  //will see failures
5. Do remove-brick commit // will pass

Actual results:
===============
remove brick commit is happening with re-balance failure


Expected results:
=================
remove-brick commit should not happen when re-balance failed.



Additional info:
Comment 3 krishnaram Karthick 2016-06-24 04:17:27 EDT

*** This bug has been marked as a duplicate of bug 1258875 ***

Note You need to log in before you can comment on or make changes to this bug.