This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1288475 - SSL enabled undercloud doesn't set the Ceilometer URL to https protocol
SSL enabled undercloud doesn't set the Ceilometer URL to https protocol
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-cloud-config (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Ben Nemec
Marius Cornea
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 06:14 EST by Marius Cornea
Modified: 2016-04-07 17:43 EDT (History)
7 users (show)

See Also:
Fixed In Version: os-cloud-config-0.3.0-4.el7ost
Doc Type: Bug Fix
Doc Text:
A bug in the Identity service's endpoint registration code failed to mark the Telemetry service as SSL-enabled. This prevented the Telemetry service endpoint from being registered as HTTPS. This update fixes the bug: the Identity service now correctly registers Telemetry, and Telemetry traffic is now encrypted as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:43:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 276329 None None None 2016-02-23 08:35 EST

  None (edit)
Description Marius Cornea 2015-12-04 06:14:23 EST
Description of problem:
When deploying an SSL enabled undercloud all the Ceilometer endpoint URLs are using http protocol.

Version-Release number of selected component (if applicable):
instack-undercloud-2.1.2-29.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy undercloud with SSL 
2. keystone endpoint-list | grep 8777

Actual results:
| 2bb46bd274fa41ef88e5e42af7d69432 | regionOne |             http://192.0.2.2:8777/            |            http://192.0.2.1:8777/           |         http://192.0.2.1:8777/         | 4e228453b4bd41b2b9a8b6acf63e3197 |

Expected results:
I'd expect the public endpoint to be set to https as the other endpoints are set.
Comment 2 Ben Nemec 2016-01-05 14:51:39 EST
This should be fixed in 8.0.  The latest ssl undercloud change isn't using os-cloud-config to set the endpoints (which is why they were wrong in 7.0) and it does set ceilometer to https.
Comment 4 Marius Cornea 2016-02-29 07:03:25 EST
os-cloud-config-0.3.0-4.el7ost.noarch

| 5c419b0958664c45a755b147e9cf5ffe | regionOne |            https://192.0.2.2:13777            |            http://192.0.2.1:8777            |         http://192.0.2.1:8777          | e145d23ec38c4e60a60d9a190d1e89ac |
Comment 6 errata-xmlrpc 2016-04-07 17:43:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.