Bug 1288485 - [RFE] Support Host Keytab renewal
[RFE] Support Host Keytab renewal
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: adcli (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Sumit Bose
Stefan Dordevic
: FutureFeature
Depends On:
Blocks: 1292074 1296125 1313485 1290731
  Show dependency treegraph
 
Reported: 2015-12-04 06:30 EST by Martin Kosek
Modified: 2016-11-04 02:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: adcli-0.8.1-1.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1290731 (view as bug list)
Environment:
Last Closed: 2016-11-04 02:22:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 92908 None None None Never

  None (edit)
Description Martin Kosek 2015-12-04 06:30:12 EST
Description of problem:

Support Active Directory keytab renewal, so that clients can be configured to renew the keytabs periodically. This functionality is especially useful when client is joined to Active Directory with enforced maximum password life.

Windows machines do the renewal automatically, in RHEL we would like to use adcli to renew the keytab. The renewal can be triggered by cron in the start and by SSSD in the future.
Comment 1 Sumit Bose 2015-12-04 06:53:23 EST
The feature is tracked upstream at https://bugs.freedesktop.org/show_bug.cgi?id=92908
Comment 7 errata-xmlrpc 2016-11-04 02:22:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2428.html

Note You need to log in before you can comment on or make changes to this bug.