Bug 128851 - autofs causing kernel oops?
Summary: autofs causing kernel oops?
Status: CLOSED DUPLICATE of bug 118413
Alias: None
Product: Fedora
Classification: Fedora
Component: autofs   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Moyer
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-30 15:45 UTC by Brent Fox
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brent Fox 2004-07-30 15:45:28 UTC
I came in to work this morning to find my machine in a rather strange
state.  It wasn't completely hard locked, but I could not log in with
my NIS username and password.  Looking around in /var/log/messages, I
found the following information:

Jul 30 04:02:08 verve automount[8981]: BUG: /home/devel already mounted
Jul 30 04:02:08 verve automount[8982]: BUG: /home/devel already mounted
Jul 30 04:02:10 verve logrotate: ALERT exited abnormally with [1]
Jul 30 10:01:17 verve kernel: Badness in interruptible_sleep_on at
kernel/sched.c:1927
Jul 30 10:01:17 verve kernel: Call Trace:
Jul 30 10:01:17 verve kernel:  [<0229fe72>]
interruptible_sleep_on+0x5a/0xc6
Jul 30 10:01:17 verve kernel:  [<0211b419>] default_wake_function+0x0/0xc
Jul 30 10:01:17 verve kernel:  [<428814f9>] autofs4_wait+0x1fe/0x25e
[autofs4]
Jul 30 10:01:17 verve kernel:  [<428805e5>]
try_to_fill_dentry+0xa8/0x100 [autofs4]
Jul 30 10:01:17 verve kernel:  [<02159950>] do_lookup+0x54/0x72
Jul 30 10:01:17 verve kernel:  [<02159c7e>] link_path_walk+0x310/0x7d0
Jul 30 10:01:17 verve kernel:  [<0215a42b>] path_lookup+0x13f/0x16f
Jul 30 10:01:17 verve kernel:  [<0215a567>] __user_walk+0x21/0x51
Jul 30 10:01:17 verve automount[12558]: BUG: /home/devel already mounted
Jul 30 10:01:17 verve kernel:  [<02156177>] vfs_stat+0x14/0x3a
Jul 30 10:01:17 verve kernel:  [<02140c53>] follow_page+0x128/0x134
Jul 30 10:01:17 verve kernel:  [<0214c50b>] rw_vm+0x20b/0x234
Jul 30 10:01:17 verve kernel:  [<021566e9>] sys_stat64+0xf/0x23
Jul 30 10:01:17 verve kernel:  [<0212952b>] sys_setresuid+0x17a/0x187
Jul 30 10:01:17 verve kernel:
Jul 30 10:02:35 verve kernel: Badness in interruptible_sleep_on at
kernel/sched.c:1927
Jul 30 10:02:35 verve kernel: Call Trace:
Jul 30 10:02:35 verve automount[12571]: BUG: /home/devel already mounted
Jul 30 10:02:35 verve kernel:  [<0229fe72>]
interruptible_sleep_on+0x5a/0xc6
Jul 30 10:02:35 verve kernel:  [<0211b419>] default_wake_function+0x0/0xc
Jul 30 10:02:35 verve kernel:  [<428814f9>] autofs4_wait+0x1fe/0x25e
[autofs4]
Jul 30 10:02:35 verve kernel:  [<428805e5>]
try_to_fill_dentry+0xa8/0x100 [autofs4]
Jul 30 10:02:35 verve kernel:  [<02159950>] do_lookup+0x54/0x72
Jul 30 10:02:35 verve kernel:  [<02159c7e>] link_path_walk+0x310/0x7d0
Jul 30 10:02:35 verve kernel:  [<0215a42b>] path_lookup+0x13f/0x16f
Jul 30 10:02:35 verve kernel:  [<0215a567>] __user_walk+0x21/0x51
Jul 30 10:02:35 verve kernel:  [<02156177>] vfs_stat+0x14/0x3a
Jul 30 10:02:35 verve kernel:  [<02140c53>] follow_page+0x128/0x134
Jul 30 10:02:35 verve kernel:  [<0214c50b>] rw_vm+0x20b/0x234
Jul 30 10:02:35 verve kernel:  [<021566e9>] sys_stat64+0xf/0x23
Jul 30 10:02:35 verve kernel:  [<0212952b>] sys_setresuid+0x17a/0x187
Jul 30 10:02:35 verve kernel:

As far as I know, the machine had just been sitting idle since I left
work yesterday.  This is with Fedora Core 2, autofs-4.1.2-2,
kernel-2.6.5-1.358.  Please let me know if there's anything else I can
do to provide you more information.

Comment 1 Jeff Moyer 2004-08-03 14:34:58 UTC

*** This bug has been marked as a duplicate of 118413 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:04:47 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.