Bug 1288513 - support new libvirt events
support new libvirt events
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.5
Unspecified Unspecified
high Severity low
: ovirt-3.5.7
: ---
Assigned To: Francesco Romani
meital avital
virt
: ZStream
Depends On: 1284564
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 08:16 EST by Michal Skrivanek
Modified: 2016-02-10 14:24 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1284564
Environment:
Last Closed: 2015-12-04 08:53:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48789 None None None Never
oVirt gerrit 48790 None None None Never
oVirt gerrit 49017 None None None Never
oVirt gerrit 49673 ovirt-3.5 ABANDONED vm: reformat _EVENT_STRINGS Never
oVirt gerrit 49674 ovirt-3.5 ABANDONED vm: add support for "Crashed" event Never
oVirt gerrit 49675 ovirt-3.5 ABANDONED vm: more robust support of event strings Never

  None (edit)
Description Michal Skrivanek 2015-12-04 08:16:07 EST
Setting prio to high since we expect quite a long time before 3.6 is widely adopted and we want to avoid log errors when it's easy to fix. Patches are ready

+++ This bug was initially created as a clone of Bug #1284564 +++

Description of problem:
Libvirt 1.2.17 (but maybe before) added a new "Crashed" event which VDSM doesn't support yet.
In general, VDSM should be forward compatible with future libvirt events.


Version-Release number of selected component (if applicable):
4.16.29


How reproducible:
100%

Steps to Reproduce:
1. run VM
2. trigger "Crashed" event inside the VM
3.

Actual results:
VDSM could not handle the event, dumps a stack trace


Expected results:
VDSM handles the event, and ignores if it haves to. No stacktraces are generated.


Additional info:
The stracktrace currently VDSM dumps is because VDSM just fails at the start of the handling of the event. There is no loss of functionalty because VDSM will just log the event without doing any further action
Comment 1 Michal Skrivanek 2015-12-04 08:53:02 EST
after all this seem to happen only on ppc, x86 guests do not seem to use a pvpanic device which triggers this event. Let's not waste time on 3.5 then

Note You need to log in before you can comment on or make changes to this bug.