Bug 1288535 - [7.2_3.5][node]"Error replacing '/etc/passwd': Device or resource busy" occurs when upgrade from 7.1 to RHEV-H 7.2
[7.2_3.5][node]"Error replacing '/etc/passwd': Device or resource busy" occur...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.6
Unspecified Unspecified
high Severity high
: ovirt-3.5.8
: 3.5.8
Assigned To: Ryan Barry
Huijuan Zhao
: Reopened, ZStream
Depends On: 1263648
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 09:22 EST by rhev-integ
Modified: 2016-02-29 09:50 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1263648
Environment:
Last Closed: 2016-02-29 09:50:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: ovirt-node-3.2.3-30.el6 ovirt-node-3.2.3-30.el7
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48216 master ABANDONED password: Replace libuser and update the persist/unpersist calls Never
oVirt gerrit 49325 master MERGED recipe: Let udevd use a recursive slave mnt namespace Never
oVirt gerrit 49526 ovirt-3.6 MERGED recipe: Let udevd use a recursive slave mnt namespace Never
oVirt gerrit 51292 ovirt-3.5 MERGED init: Ensure that /etc will be a rshared subtree 2016-01-06 11:57 EST

  None (edit)
Comment 2 Huijuan Zhao 2015-12-11 01:56:28 EST
QE do not get build to verify now, I will verify this bug after QE get build and there is build version in "Fixed In Version".
Comment 3 Huijuan Zhao 2016-01-04 00:55:33 EST
Still encounter this issue in 

Test version:
rhev-hypervisor-7-7.2-20151229.1.el7ev
ovirt-node-3.2.3-30.el7.noarch

Test Steps:
1. Clean install rhev-hypervisor-7-7.1-20151015.0
2. TUI Upgrade to rhev-hypervisor-7-7.2-20151229.1.el7ev
3. Setting new password during upgrade.

Actual results:
1. after step3, there is error report:
Exception: System error("Error replacing '/etc/passwd': Device or resource busy",)

Expected results:
after step3, upgrade should be successful

So this bug is not fix in rhev-hypervisor-7-7.2-20151229.1.el7ev (ovirt-node-3.2.3-30.el7.noarch), change the status to ASSIGNED.
Comment 4 Fabian Deutsch 2016-01-04 06:12:00 EST
It looks like an additional patch needed a backport to ovirt-3.5
Comment 7 Huijuan Zhao 2016-02-02 22:27:41 EST
Test version:
rhev-hypervisor-7-7.2-20160128.1.el7ev
ovirt-node-3.2.3-31.el7.noarch

Test Steps:
1. Clean install rhev-hypervisor-7-7.1-20151015.0
2. TUI Upgrade to rhev-hypervisor-7-7.2-20160128.1.el7ev
3. Setting new password during upgrade.

Test results:
1. after step3, upgrade successful

So this bug is fixed in rhev-hypervisor-7-7.2-20160128.1.el7ev, change the status to VERIFIED.
Comment 9 errata-xmlrpc 2016-02-29 09:50:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0316.html

Note You need to log in before you can comment on or make changes to this bug.