Bug 1288537 - [Docs] Use an auto-generated certificate for the Kibana deployer secret
[Docs] Use an auto-generated certificate for the Kibana deployer secret
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Vikram Goyal
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 09:24 EST by Jean-Francois Saucier
Modified: 2017-12-30 08:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-30 08:52:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Francois Saucier 2015-12-04 09:24:59 EST
Document URL: 
https://access.redhat.com/documentation/en/openshift-enterprise/version-3.1/installation-and-configuration/#pre-deployment-configuration

Section Number and Name: 
14.2, step 2

Describe the issue: 
In this step, we need to generate the deployer secret. The documentation describe each type of certificate and what they do. After that, there is a command to generate the secret using already created key and crt.

But, it's not clear that we can use an auto-generated secret with the following command : "oc secrets new logging-deployer nothing=/dev/null"

Suggestions for improvement: 
This command is already suggested in section 15.5.1. It's also in the upstream documentation : https://github.com/openshift/origin-aggregated-logging/tree/master/deployment#create-the-deployer-secret

Additional information:
Comment 1 Vikram Goyal 2017-12-30 08:52:48 EST
Looks like we updated the text to specify that it is autogenerated cert.

Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.