Bug 1288555 - Add pacemaker_remote support in the pacemaker module
Add pacemaker_remote support in the pacemaker module
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
All Linux
medium Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Gaël Chamoulaud
Asaf Hirshberg
:
Depends On:
Blocks: 1185030
  Show dependency treegraph
 
Reported: 2015-12-04 09:50 EST by Michele Baldessari
Modified: 2016-04-07 17:16 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.3-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:16:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michele Baldessari 2015-12-04 09:50:21 EST
Description of problem:
Currently the last openstack-puppet-modules package (7.0.1-2) does not have pacemaker_remote support. In order to be able to deploy instance HA, it is
quite useful to have it in order to deploy it automatically via ospd.

On a local test I added the following commits to the pacemaker module:
23cbb084bf48c414c189f45a3761c57ba8375d1 Merge pull request #63 from cwolferh/remote_authkey
constraints
23580239ac495fc20bd4a393a36051ab49ac9fa Ability to set authkey for pacemaker-remote.                

and was able to correctly  set authkey on the controller nodes.

Setting it on the compute nodes was slightly a bit more hand-work, but I could
not see any commit upstream to support it nicely, so this BZ is just to cover the controller nodes.

Version-Release number of selected component (if applicable):
7.0.1-2
Comment 2 Gaël Chamoulaud 2015-12-07 04:01:39 EST
The appropriate commit is already part of the opm master, just need a new build.

[1] - https://github.com/redhat-openstack/openstack-puppet-modules/blob/master/Puppetfile#L185-L187
Comment 5 Asaf Hirshberg 2016-03-16 05:48:26 EDT
Hey Michele,

Can you please provide me the steps in order to verify this bug?

Thanks.
Comment 6 Michele Baldessari 2016-03-16 06:16:20 EDT
Hi Asaf,

this puppet remote support is not yet used within director as that work has been postponed. You can just SanityOnly here. The functionality does work, but the templates making use of it are not yet ready (and won't be for OSP 8)

If you absolutely must test it, we can probably think of something (you will need
two vms, we can install puppet + OPM on them and then run a couple of manifests,
which I would  need to prepare), but I think it makes little sense for the effort
required.

hope this helps. Let me know if it does not,
Michele
Comment 7 Asaf Hirshberg 2016-04-03 00:40:29 EDT
Michele,

I ran sanity on setup deployed with ospd8 and the desired rpm[1], sanity passed cleanly.
Comment 8 errata-xmlrpc 2016-04-07 17:16:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.