Bug 1288586 - ebtables systemd init script wrong permissions
ebtables systemd init script wrong permissions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ebtables (Show other bugs)
7.1
All Linux
low Severity low
: rc
: ---
Assigned To: Thomas Woerner
Tomas Dolezal
:
: 1311546 1360661 1392237 (view as bug list)
Depends On:
Blocks: 1203710 1296594 1313485
  Show dependency treegraph
 
Reported: 2015-12-04 11:39 EST by David Brown
Modified: 2016-11-07 06:16 EST (History)
11 users (show)

See Also:
Fixed In Version: ebtables-2.0.10-14.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:10:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2080483 None None None 2016-01-20 09:18 EST

  None (edit)
Description David Brown 2015-12-04 11:39:46 EST
Description of problem:
ebtables systemd init script has the executable bits set from the RPM. Systemd complains profusely about this in syslog.

Version-Release number of selected component (if applicable):
# rpm -qi ebtables
Name        : ebtables
Version     : 2.0.10
Release     : 13.el7
Architecture: x86_64
Install Date: Fri 04 Dec 2015 08:15:42 AM PST
Group       : System Environment/Base
Size        : 350432
License     : GPLv2+
Signature   : RSA/SHA256, Tue 01 Apr 2014 08:01:38 AM PDT, Key ID 199e2f91fd431d51
Source RPM  : ebtables-2.0.10-13.el7.src.rpm
Build Date  : Tue 04 Mar 2014 04:05:21 AM PST
Build Host  : x86-021.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://ebtables.sourceforge.net/
Summary     : Ethernet Bridge frame table administration tool
Description :
Ethernet bridge tables is a firewalling tool to transparently filter network
traffic passing a bridge. The filtering possibilities are limited to link
layer filtering and some basic filtering on higher network layers.

This tool is the userspace control for the bridge and ebtables kernel
components.

The ebtables tool can be used together with the other Linux filtering tools,
like iptables. There are no known incompatibility issues.
# rpm -q --dump ebtables | grep systemd
/usr/lib/systemd/system/ebtables.service 208 1393934573 b95ca5c1ab8f8be1946d290a680d3aae5a2037b003841b461a88fdaf1f19013d 0100755 root root 0 0 0 X

How reproducible:
Very

Steps to Reproduce:
1. install ebtables
2. rpm -q --dump ebtables | grep systemd
3. inspect permissions column of output

Actual results:
0100755

Expected results:
0100644

Additional info:
Hopefully you guys have this fixed in newer versions of RHEL 7, if not, here's the bug.
Comment 6 Thomas Woerner 2016-05-17 14:40:15 EDT
*** Bug 1311546 has been marked as a duplicate of this bug. ***
Comment 8 Thomas Woerner 2016-08-08 05:09:37 EDT
*** Bug 1360661 has been marked as a duplicate of this bug. ***
Comment 11 errata-xmlrpc 2016-11-04 01:10:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2388.html
Comment 12 Thomas Woerner 2016-11-07 06:16:36 EST
*** Bug 1392237 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.