Bug 1288636 - Access to the payload class unavailable from anaconda addons
Access to the payload class unavailable from anaconda addons
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jiri Konecny
Release Test Team
:
Depends On:
Blocks: 1394153
  Show dependency treegraph
 
Reported: 2015-12-04 15:14 EST by Pat Riehecky
Modified: 2016-11-11 03:28 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.68-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1394153 (view as bug list)
Environment:
Last Closed: 2016-11-03 19:20:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pat Riehecky 2015-12-04 15:14:36 EST
Description of problem:
Ultimately, I'm trying to get access to whatever implements
pyanaconda.packaging.Payload in the installing system.  From my reading of
pyanaconda.install ( around line 260 ) it doesn't look like payload is
exposed to the addons.

Version-Release number of selected component (if applicable):anaconda-21.48.22.56-1 


How reproducible:100%


Steps to Reproduce:
1.Attempt to read the payload object from within the addons
2.
3.

Actual results:
unable to read the install payload from any anacoda addon

Expected results:
able to read the install payload from any anacoda addon

Additional info:
https://www.redhat.com/archives/anaconda-devel-list/2015-December/msg00009.html
Comment 4 Jiri Konecny 2016-03-30 05:49:54 EDT
PR: https://github.com/rhinstaller/anaconda/pull/571
Comment 5 Jiri Konecny 2016-04-26 04:41:38 EDT
The patch is pushed now.
You can test the functionality with the following addon 

https://github.com/jkonecny12/hello-world-anaconda-addon/tree/master-payload-testing

This addon only do a simple use of the payload class but you can of course modify it as you want.
Comment 7 Peter Kotvan 2016-09-01 08:18:41 EDT
I've reproduced this bug on RHEL-7.2 GA with anaconda-21.48.22.56-1.el7, verified on RHEL-7.3-20160825.1 with anaconda-21.48.22.86-1.el7.
Comment 9 errata-xmlrpc 2016-11-03 19:20:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html
Comment 10 Dave Young 2016-11-10 21:05:02 EST
Hi,

Kdump addon does not access the payload, so leave it as is without update the addon is safe? If yes I would only update it when have to..

Thanks
Dave
Comment 11 Jiri Konecny 2016-11-11 02:48:02 EST
Hello Dave,

You are now using deprecated API so I would like to see Kdump addon updated. However, the new code is backward compatible and it just prints warning about using deprecated function signature.

I don't think we will remove this deprecated API any time soon so it should work properly for now.

Jirka
Comment 12 Dave Young 2016-11-11 03:28:29 EST
Ok, then I cloned a RHEL7.4 bug 1394153 for kdump addon.

Thanks a lot!

Note You need to log in before you can comment on or make changes to this bug.