Bug 1288688 - python-parsedatetime: Build epel7 branch
python-parsedatetime: Build epel7 branch
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-parsedatetime (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michele Baldessari
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1288743
  Show dependency treegraph
 
Reported: 2015-12-04 20:53 EST by Robert Buchholz
Modified: 2015-12-10 05:28 EST (History)
3 users (show)

See Also:
Fixed In Version: python-parsedatetime-1.5-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 05:28:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test-failure-eom-is-correct-but-expectation-is-wrong.patch (1.27 KB, application/mbox)
2015-12-04 20:53 EST, Robert Buchholz
no flags Details
0001-Fix-test-failure-in-December.patch (3.20 KB, patch)
2015-12-04 20:54 EST, Robert Buchholz
no flags Details | Diff

  None (edit)
Description Robert Buchholz 2015-12-04 20:53:36 EST
Created attachment 1102486 [details]
test-failure-eom-is-correct-but-expectation-is-wrong.patch

python-parsedatetime is already approved for EPEL7, but has no package built yet. This is required for the official reference letsencrypt client in EPEL7.

I got this to build successfully, following these steps:
1. Merge pkggit master to epel7 branch, package is already conditional on python3
2. Fix spurious test failure

The package has a bug in a test (rebuild currently fails in rawhide, and epel7). I have reported this upstream and provided a fix that already got merged [1]. I also backported the fix to the latest release (mostly whitespace changes in between) and I'll attach it to this bug.

If you plan or expect a rebuild this month for any reason, you could add the patch to rawhide.

[1] https://github.com/bear/parsedatetime/pull/146
Comment 1 Robert Buchholz 2015-12-04 20:54 EST
Created attachment 1102487 [details]
0001-Fix-test-failure-in-December.patch

patch for the specfile
Comment 2 Itamar Reis Peixoto 2015-12-05 17:37:48 EST
I think if you post the link of the srpm with the patches on it should make our life ease because we can import it using fedpkg import, what do you think about that ?
Comment 3 Robert Buchholz 2015-12-05 18:24:46 EST
Sure, didn't know this was easier for you. The srpms are on COPR:
https://copr-be.cloud.fedoraproject.org/results/rbu/letsencrypt/epel-7-x86_64/00144747-python-parsedatetime/python-parsedatetime-1.5-3.el7.centos.src.rpm
Comment 4 Itamar Reis Peixoto 2015-12-05 20:53:15 EST
Michele Baldessari, Can you import and build this package ?
Comment 5 Michele Baldessari 2015-12-07 09:15:49 EST
Yes, will work on it tonight or tomorrow
Comment 6 Fedora Update System 2015-12-08 10:09:24 EST
python-parsedatetime-1.5-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-73787f12fc
Comment 7 Michele Baldessari 2015-12-08 14:40:16 EST
Not sure why Nick could not wait for the day and a half I had asked for in c5

Anyway, no huge deal. Itamar, I gave you ACL rights so feel free to take care of BZ 1288812 as well.
I won't be touching the epel 7/el6 branches at this point, so go wild.
Comment 8 Fedora Update System 2015-12-09 00:20:42 EST
python-parsedatetime-1.5-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update python-parsedatetime'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-73787f12fc
Comment 9 Fedora Update System 2015-12-10 05:28:20 EST
python-parsedatetime-1.5-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.