Bug 1288693 - libblockdev update requires python2
libblockdev update requires python2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libblockdev (Show other bugs)
22
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-05 00:31 EST by louisgtwo
Modified: 2015-12-07 06:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 06:35:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2015-12-05 00:31:12 EST
Fedora 22 workstation did not install python 2 by default. libblockdev-1.1-2.fc23.x86_64 did not require python 2. libblockdev-1.3-4.fc23.x86_64 in updates now requires python 2. This is a regression.
Comment 1 Vratislav Podzimek 2015-12-07 06:35:38 EST
It's actually not a regression, but a fix. See bug #1256758 for details. In rawhide, python* packages don't have to be installed, but to ensure everything works after update, the F23 packages need to require these. AFAICT, there's no way to ensure the clean update path and have those separate packages without requiring them from the 'libblockdev' package. If you know one, let me know and we can work on it. Meanwhile, I'm closing this as NOTABUG, because it works as expected.

Note You need to log in before you can comment on or make changes to this bug.