Bug 1288694 - samba update requires python 2
samba update requires python 2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-05 00:35 EST by louisgtwo
Modified: 2016-01-08 13:58 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-08 13:58:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2015-12-05 00:35:36 EST
Fedora 22 Workstation did not install python 2 by default. Updated samba packages now require python 2. This is a regression.
Comment 1 Alexander Bokovoy 2015-12-05 13:44:11 EST
Can you show what exactly is pulling python2 in?

Samba has python bindings which support python2 only and are used by FreeIPA server to provide interoperability with Active Directory, thus freeipa-server-trust-ad subpackage depends on samba-python which is currently only supports python2.

If you installed samba-python subpackage, it is indeed forcing use of python2. There is currently no solution to this, work to support python3 is still being done upstream.

So can you provide more details of 'regression'?
Comment 2 louisgtwo 2015-12-05 14:11:53 EST
Their seems to be new dependencies with the samba-4.3.1-3 that samba-4.3.0-0.1.rc4 did not have.

samba-common-tools = 2:4.3.1-3.fc23 is needed by samba-common-2:4.3.1-3.fc23.noarch

samba-libs = 2:4.3.1-3.fc23 is needed by samba-common-tools-2:4.3.1-3.fc23.x86_64

libpython2.7.so.1.0()(64bit) is needed by samba-libs-2:4.3.1-3.fc23.x86_64

If fedora is moving away from python2 and workstation did not install python2 by default but now requires it for updates this is a regression.
Comment 3 Alexander Bokovoy 2015-12-05 15:16:48 EST
The first two are proper dependencies, they were required to fix some other bugs. 

The third one, I think, can be moved out to samba-python. It is needed for internal Samba's python integration for the 'make test' and WAF modules and can easily go into samba-python. At least, there is no direct dependency to it other than from WAF and make test.

Note You need to log in before you can comment on or make changes to this bug.