Bug 1288727 - Handling of IDN domains are complete broken
Handling of IDN domains are complete broken
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-05 11:35 EST by Frank Büttner
Modified: 2016-01-06 05:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 05:29:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 237820 None None None 2016-01-06 05:29 EST

  None (edit)
Description Frank Büttner 2015-12-05 11:35:35 EST
Description of problem:
Using thunderbird for IDN mail domains is not possible, because the support is complete missing.

Version-Release number of selected component (if applicable):
thunderbird-38.3.0-1.fc22.x86_64

How reproducible:
Send an mail from an IDN mail account.

Steps to Reproduce:
1. Add an new mail account for an IDN like foo@müller.de
2. send an mail

Actual results:
The mails is reject by the receiver, because the header are incorrect.  

Expected results:
Send mails will work.


Additional info:
When I look in the source code of the mail, all fields, will contain the IDN and not the puny code version of the mail domain.
And also the RCPT TO:<XXX> stuff while transmit is broken.
Comment 1 Martin Stransky 2016-01-06 05:29:33 EST
It's here - https://bugzilla.mozilla.org/show_bug.cgi?id=237820

Note You need to log in before you can comment on or make changes to this bug.