Bug 1288735 - gnome software shows no updates - ever
gnome software shows no updates - ever
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-05 13:08 EST by Adam Pribyl
Modified: 2016-01-08 04:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-08 04:35:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Pribyl 2015-12-05 13:08:12 EST
Description of problem:
Gnome software never offers any updates on desktops I maintain. It says it checked data last (today?) 9:51 (now it is 19:02) but it is not showing any update notification for all the months from installing the Fedora 22. In Updates tab of the gnome-software there is always "software is up to date".

ATM: After hitting the refresh button on one of the desktops it does something for few minutes then shows a message that can not be copied and says something like "cannot download libmpg123... blabla..All mirrors tried."

dnf shows
Install    5 Packages
Upgrade  143 Packages
Remove     3 Packages

but no libmpg is listed to be updated. 

This is really troublesome, that users are not able to selfupdate their systems and it requires manual intervention from command line.


Version-Release number of selected component (if applicable):
gnome-software-3.16.6-1.fc22.x86_64


How reproducible:
All the time

Steps to Reproduce:
1. Open gnome-software
2. Click the update tab
3. Refresh
Comment 1 Richard Hughes 2015-12-07 10:46:41 EST
what does "pkcon update --only-download" say?
Comment 2 Adam Pribyl 2015-12-08 03:19:41 EST
# pkcon update --only-download
Getting updates               [=========================]         
Finished                      [=========================]         
Updating packages             [=========================]         
Starting                      [=========================]         
Querying                      [=========================]         
Downloading packages          [=========================]         
Finished                      [=========================]         
Fatal error: cannot download libmpg123-1.22.4-1.fc21.x86_64.rpm to /var/cache/PackageKit/metadata/rpmfusion-free-updates/packages/: Cannot download libmpg123-1.22.4-1.fc21.x86_64.rpm: All mirrors were tried

I do not know, where this libmpg update comes from - is it something in rpmfusion repo that is wrong?

The package is there
http://download1.rpmfusion.org/free/fedora/updates/22/x86_64/repoview/libmpg123.html

and can be downloaded
http://download1.rpmfusion.org/free/fedora/updates/22/x86_64/libmpg123-1.22.4-1.fc22.x86_64.rpm

Uh... I see it is trying to download a f21 version?! RPMfusion repo definition bug?
Comment 3 Richard Hughes 2016-01-08 04:35:58 EST
(In reply to Adam Pribyl from comment #2)
> Uh... I see it is trying to download a f21 version?! RPMfusion repo
> definition bug?

Yes, rpmfusion took a long time to fix everything. I think it's all fixed now.

Note You need to log in before you can comment on or make changes to this bug.