Bug 128876 - Ugly URLs after PaginationServlet redirects.
Ugly URLs after PaginationServlet redirects.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
Fanny Augustin
:
Depends On:
Blocks: rhnMilestone1
  Show dependency treegraph
 
Reported: 2004-07-30 15:41 EDT by Ryan Bloom
Modified: 2007-04-18 13:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-30 18:12:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ryan Bloom 2004-07-30 15:41:53 EDT
$SUMMARY
Comment 2 Jesus M. Rodriguez 2004-07-30 17:36:36 EDT
After talking with Chip tonight.  Since the PaginationServlet has
access to the ListView it should take the pagination formvars and the
ones from the listview and put those in a map.  It does NOT have to do
all of the current request params.
Comment 3 Jesus M. Rodriguez 2004-07-30 18:09:26 EDT
Took Chips advice and only put in the params we care about.  I also
refactored the PaginationServlet to make the doPost() method much more
readable.

Note You need to log in before you can comment on or make changes to this bug.