Bug 1288773 - SELinux is preventing nm-openvpn-serv from 'read' accesses on the directory /tmp.
SELinux is preventing nm-openvpn-serv from 'read' accesses on the directory /...
Status: CLOSED DUPLICATE of bug 1286964
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9a65c66f040bf5a69e175f4ff9f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-05 18:19 EST by Joachim Frieben
Modified: 2015-12-07 05:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 05:08:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2015-12-05 18:19:54 EST
Description of problem:
I tried to activate a VPN connection by means of NetworkManager-openvpn.
SELinux is preventing nm-openvpn-serv from 'read' accesses on the directory /tmp.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/tmp default label should be tmp_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /tmp

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that nm-openvpn-serv should be allowed read access on the tmp directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep nm-openvpn-serv /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                /tmp [ dir ]
Source                        nm-openvpn-serv
Source Path                   nm-openvpn-serv
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           filesystem-3.2-35.fc24.x86_64
Policy RPM                    selinux-policy-3.13.1-161.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.4.0-0.rc3.git4.1.fc24.x86_64 #1
                              SMP Fri Dec 4 16:10:15 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-12-05 23:55:22 CET
Last Seen                     2015-12-05 23:55:22 CET
Local ID                      cfc62f26-983f-438c-b2e4-db1095150f2c

Raw Audit Messages
type=AVC msg=audit(1449356122.164:578): avc:  denied  { read } for  pid=2408 comm="nm-openvpn-serv" name="/" dev="tmpfs" ino=12787 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=dir permissive=1


Hash: nm-openvpn-serv,NetworkManager_t,tmpfs_t,dir,read

Version-Release number of selected component:
selinux-policy-3.13.1-161.fc24.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.4.0-0.rc3.git4.1.fc24.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2015-12-07 05:08:15 EST

*** This bug has been marked as a duplicate of bug 1286964 ***

Note You need to log in before you can comment on or make changes to this bug.