Bug 1288778 - bchunk gives corrupt wav files
bchunk gives corrupt wav files
Status: CLOSED DUPLICATE of bug 439661
Product: Fedora
Classification: Fedora
Component: bchunk (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-05 18:37 EST by XieOz
Modified: 2015-12-06 15:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-06 15:12:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description XieOz 2015-12-05 18:37:52 EST
Description of problem:

bchunk gives corrupt wav files

Version-Release number of selected component (if applicable):

bchunk 1.2.0 (Fedora 23) : bchunk-1.2.0-17.fc23.x86_64

How reproducible:

With a big wav file : 591M and a cue file

Steps to Reproduce: (with flac-1.3.1-5.fc23.x86_64)

#bchunk -w cd.wav cd.cue splitwav
binchunker for Unix, version 1.2.0 by Heikki Hannikainen <hessu@hes.iki.fi>
        Created with the kind help of Bob Marietta <marietrg@SLU.EDU>,
        partly based on his Pascal (Delphi) implementation.
        Support for MODE2/2352 ISO tracks thanks to input from
        Godmar Back <gback@cs.utah.edu>, Colas Nahaboo <Colas@Nahaboo.com>
        and Matthew Green <mrg@eterna.com.au>.
        Released under the GNU GPL, version 2 or later (at your option).

Reading the CUE file:

Track  1: AUDIO         01 00:00:00
Track  2: AUDIO         00 02:54:57 01 02:56:57
Track  3: AUDIO         00 06:45:54 01 06:47:54
Track  4: AUDIO         00 10:53:00 01 10:55:00
Track  5: AUDIO         00 15:48:74 01 15:50:74
Track  6: AUDIO         00 21:01:25 01 21:03:25
Track  7: AUDIO         00 24:26:11 01 24:28:11
Track  8: AUDIO         00 30:00:58 01 30:02:58
Track  9: AUDIO         00 34:09:06 01 34:11:06
Track 10: AUDIO         00 37:07:00 01 37:09:00
Track 11: AUDIO         00 40:22:46 01 40:24:46
Track 12: AUDIO         00 44:04:14 01 44:06:14
Track 13: AUDIO         00 47:44:36 01 47:46:36
Track 14: AUDIO         00 50:21:55 01 50:23:55
Track 15: AUDIO         00 54:39:74 01 54:41:74

Writing tracks:

 1: splitwav01.wav   29/29   MB  [********************] 100 %
 2: splitwav02.wav   38/38   MB  [********************] 100 %
 3: splitwav03.wav   41/41   MB  [********************] 100 %
 4: splitwav04.wav   49/49   MB  [********************] 100 %
 5: splitwav05.wav   52/52   MB  [********************] 100 %
 6: splitwav06.wav   34/34   MB  [********************] 100 %
 7: splitwav07.wav   55/55   MB  [********************] 100 %
 8: splitwav08.wav   41/41   MB  [********************] 100 %
 9: splitwav09.wav   29/29   MB  [********************] 100 %
10: splitwav10.wav   32/32   MB  [********************] 100 %
11: splitwav11.wav   36/36   MB  [********************] 100 %
12: splitwav12.wav   36/36   MB  [********************] 100 %
13: splitwav13.wav   26/26   MB  [********************] 100 %
14: splitwav14.wav   43/43   MB  [********************] 100 %
15: splitwav15.wav   38/38   MB  [********************] 100 %

#flac splitwav*

flac 1.3.1, Copyright (C) 2000-2009  Josh Coalson, 2011-2014  Xiph.Org Foundation
flac comes with ABSOLUTELY NO WARRANTY.  This is free software, and you are
welcome to redistribute it under certain conditions.  Type `flac' for details.

splitwav01.wav: wrote 22119771 bytes, ratio=0.718
splitwav02.wav: wrote 29707166 bytes, ratio=0.736
splitwav03.wav: wrote 34817888 bytes, ratio=0.805
splitwav04.wav: wrote 36982594 bytes, ratio=0.713
splitwav05.wav: wrote 43107106 bytes, ratio=0.787
splitwav06.wav: wrote 26333767 bytes, ratio=0.736
splitwav07.wav: wrote 42612510 bytes, ratio=0.726
splitwav08.wav: wrote 31985894 bytes, ratio=0.736
splitwav09.wav: wrote 23518362 bytes, ratio=0.758
splitwav10.wav: wrote 25728014 bytes, ratio=0.753
splitwav11.wav: wrote 30373916 bytes, ratio=0.784
splitwav12.wav: wrote 30964307 bytes, ratio=0.804
splitwav13.wav: wrote 21204966 bytes, ratio=0.774
splitwav14.wav: wrote 31063667 bytes, ratio=0.687
splitwav15.wav: 93% complete, ratio=0.654splitwav15.wav: WARNING: unexpected EOF; expected 10156524 samples, got 10153984 samples
100% complete, ratio=0.651

Actual results:
unexpected EOF

Additional info:
Same test with shntool (shntool-3.0.10-11.fc23.x86_64) and no problems, and for the same track, file size (wav and final flac) produced with bchunk are different from those from shnsplit.

#shntool split -f cd.cue -o "wav" cd.wav
shntool [split]: warning: discarding initial zero-valued split point
Splitting [cd.wav] (58:32.21) --> [split-track01.wav] (2:56.57) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track02.wav] (3:50.72) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track03.wav] (4:07.21) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track04.wav] (4:55.74) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track05.wav] (5:12.26) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track06.wav] (3:24.61) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track07.wav] (5:34.47) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track08.wav] (4:08.23) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track09.wav] (2:57.69) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track10.wav] (3:15.46) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track11.wav] (3:41.43) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track12.wav] (3:40.22) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track13.wav] (2:37.19) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track14.wav] (4:18.19) : 100% OK
Splitting [cd.wav] (58:32.21) --> [split-track15.wav] (3:50.22) : 100% OK

#flac split-track*

flac 1.3.1, Copyright (C) 2000-2009  Josh Coalson, 2011-2014  Xiph.Org Foundation
flac comes with ABSOLUTELY NO WARRANTY.  This is free software, and you are
welcome to redistribute it under certain conditions.  Type `flac' for details.

split-track01.wav: wrote 22117925 bytes, ratio=0.709
split-track02.wav: wrote 29709831 bytes, ratio=0.729
split-track03.wav: wrote 34818816 bytes, ratio=0.798
split-track04.wav: wrote 36982659 bytes, ratio=0.708
split-track05.wav: wrote 43107584 bytes, ratio=0.782
split-track06.wav: wrote 26333979 bytes, ratio=0.729
split-track07.wav: wrote 42612684 bytes, ratio=0.722
split-track08.wav: wrote 31986827 bytes, ratio=0.730
split-track09.wav: wrote 23519056 bytes, ratio=0.749
split-track10.wav: wrote 25728948 bytes, ratio=0.746
split-track11.wav: wrote 30374584 bytes, ratio=0.777
split-track12.wav: wrote 30964744 bytes, ratio=0.797
split-track13.wav: wrote 21205125 bytes, ratio=0.764
split-track14.wav: wrote 31065696 bytes, ratio=0.682
split-track15.wav: wrote 26438973 bytes, ratio=0.651
Comment 1 Conrad Meyer 2015-12-06 15:12:03 EST
If the patch from #439661 doesn't work (which appears to be the case) and shntool works, just use shntool.

*** This bug has been marked as a duplicate of bug 439661 ***

Note You need to log in before you can comment on or make changes to this bug.