Bug 128879 - Break perl-libxml-enno into component CPAN modules
Break perl-libxml-enno into component CPAN modules
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-libxml-enno (Show other bugs)
rawhide
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
: FutureFeature
Depends On: 167997 172330 172331 172332
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2004-07-30 16:15 EDT by Blair Zajac
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 10:34:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Blair Zajac 2004-07-30 16:15:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

Description of problem:
Hello,

The perl-libxml-enno-1.02-30 package is getting a little old in the
tooth and many of the modules in libxml-enno-1.02.tar.gz have been
superceeded by modules in CPAN.

I'm thinking it would be a good time to replace perl-libxml-enno
with its component packages.  While this may be a decent amount
of work, I'd be glad to help out and there are some good reasons
listed below.

First, the justification, from XML-DOM-1.43/Changes:
1.32 (tjmather) 8/25/2001
- Separated out XML::UM, XML::Filter::* and XML::Builder::* modules
        into separate distributions (Idea of Matt Sergeant, as 
        discussed on perl-xml@listserver.activestate.com)

Here are the modules in perl-libxml-enno and the current versions
in CPAN:

Name                            enno    CPAN
--------------------------------------------
XML::Checker                    0.09    0.13
XML::DOM                        1.27    1.43
XML::Filter::DetectWS           undef   0.01
XML::Filter::Reindent           undef   0.03
XML::Filter::SAXT               undef   undef
XML::Handler::Composer          undef   0.01
XML::Handler::PrintEvents       undef   0.01
XML::RegExp                     undef   0.02
XML::UM                         undef   0.01
XML::XQL                        0.63    0.68

The changes in XM:::DOM are not insigificant:

Change History for XML-DOM:

1.43 (tjmather) 07/28/2003
- Fixed bug that manifests itself with XML::Parser 2.32 and greater,
specify external style as 'XML::Parser::Dom' rather than just 'Dom'.
(Matt Sergeant)

1.42 (tjmather) 12/05/2002
- Fixed bug where XML::DOM doesn't encode some characters in
attribute values under Perl 5.8.0 (Steve Hay)
- Added t/dom_encode.t test to check encoding on attribute values
- Fixed warning message and use in XML::DOM::PerlSAX (Mike Castle)

1.41 (tjmather) 10/19/2002
- included XML-Parser-2.31.patch, required for XML::Parser
to work with 5.8.0 unicode
- use utf8 in unicode test scripts, fixes 5.8.0 test failures
NOTE - you should use the utf8 pragma in your programs if you
are passing utf8 to XML::DOM.
- only use encodeText for Perl < 5.6.0
- replace match w/ substitution in AttDef::new, workaround for 5.8.0
unicode
- replace match w/ substitution in Default handler for non-paramter
entity reference, workaround for 5.8.0 unicode

1.40 (tjmather) 10/13/2002
- Fixed problem when defining user LWP object (Willems Luc)
- Autodetect whether to 'use bytes' (Ed Avis)
- Added dispose method to XML::DOM::Parser Synopsis (Ruben Diez)
- Fixed warning message in Attr.getValue method (Christian Lizell)

1.39 (tjmather) 04/16/2002
- Deletes value if both System ID and value are defined
  (Brian Thomas)
- Fixed bug, now TextNode->getData doesn't expand entities when
  NoExpand => 1, added t/dom_noexpand.t test script (Brian Thomas)

1.38 (tjmather) 04/05/2002
- Removed bin/pretty.pl, it is now in XML-Filter-Reindent
- Removed return from addCDATA function to fix memory leak
  (Steve Hay)
- Added missing _to_sax method to ProcessingInstruction class
  (Patrick Whittle)
- Removed extranous debugging statement from ExternEnt subroutine
  (Jon Grov)

1.37 (tjmather) 02/15/2002
- parameter should be last argument of DocumentType::addEntity
  (Patrick Whittle)

1.36 (tjmather) 01/04/2002
- Replaced 'our' with 'my' in t/dom_text.t, to work with perl < 5.6.0

1.35 (tjmather) 10/26/2001
- Fixed bug with XML::DOM::Comment::_to_sax (Mark Pundsack)
- Added test for XML::DOM::Text::splitText (Michael Guennewig)

1.34 (tjmather) 10/07/2001
- Fixed bug with XML::DOM::Text::splitText (Michael Guennewig)
- The '>' character is now encoded in attribute values (Stephen Crowley)
- hasFeature now is case-insensitve for name of feature and
        the version defaults to 1.0, in accordance with the DOM 1.0
        standard. (Wolfgang Mauerer)

1.33 (tjmather) 8/29/2001
- Added use bytes pragma to XML::DOM to fix unicode problems.

Blair


Version-Release number of selected component (if applicable):
perl-libxml-enno-1.02-30

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:
Comment 1 Warren Togami 2005-05-31 00:50:47 EDT
The key question here is, what is the benefit?
Do those split out packages continue to get updates upstream?
Comment 2 Ville Skyttä 2005-09-07 16:36:03 EDT
Yes, in particular the most important one, XML-DOM; the latest one is from  
~1.5 months ago compared to latest libxml-enno from ~5.5 _years_ ago.  
  
If implemented completely, the split would be into (possible new prerequisites  
of these not checked):  
   
http://search.cpan.org/dist/XML-DOM/   
http://search.cpan.org/dist/XML-Checker/   
http://search.cpan.org/dist/XML-Filter-DetectWS/   
http://search.cpan.org/dist/XML-Filter-Reindent/   
http://search.cpan.org/dist/XML-Filter-SAXT/   
http://search.cpan.org/dist/XML-Handler-Composer/   
http://search.cpan.org/dist/XML-Handler-PrintEvents/   
http://search.cpan.org/dist/XML-RegExp/  
http://search.cpan.org/dist/XML-UM/   
http://search.cpan.org/dist/XML-XQL/  
  
Ugh.  I suppose the majority of these could go directly to Extras or be even  
dropped (taking FC and FE dependencies into account) until/unless someone 
yells though. 
Comment 3 Warren Togami 2005-09-07 19:19:09 EDT
I need to talk to rel-eng to see what they think.
Comment 4 Warren Togami 2005-09-09 16:55:43 EDT
The Glorious Supreme Leader said,
"find out what uses it. move it all to extras :)"

Maybe it isn't possible to move to Extras, but the next step is to look at the deps.
Comment 5 Ville Skyttä 2005-09-10 04:50:39 EDT
All dependent packages:      
  rpm -q --provides perl-libxml-enno | awk '{ print $1 }' \      
  | xargs repoquery --whatrequires | sort -u      
      
Core packages (FC4):      
- foomatic: perl-libxml-enno >= 1.02 (dubious?, bug 167997)  
      
Extras packages (FE4):      
- inkscape: perl(XML::XQL), perl(XML::XQL::DOM)      
- perl-Template-Toolkit: perl(XML::DOM)      
      
So, based on the above it looks like it would suffice to:  
- Check if foomatic really requires anything in perl-libxml-enno, and modify  
  it to use perl(Foo::Bar) style dependencies as appropriate  
- Package the following in Core/Extras depending on the foomatic outcome:  
  * perl-XML-RegExp (required by perl-XML-DOM)    
  * perl-XML-DOM (required by perl-XML-XQL)    
  * perl-XML-XQL (required by inkscape)    
  * Add Obsoletes: perl-libxml-enno <= 1.02 to one (or some) of the above,    
    I'd say to perl-XML-DOM only   
Comment 6 Warren Togami 2005-09-14 03:47:07 EDT
Hi twaugh, which perl pieces if any are needed by foomatic?
Comment 7 Tim Waugh 2005-09-14 04:41:13 EDT
I have removed all the explicit dependencies on perl modules from foomatic.spec.
Comment 8 Warren Togami 2005-09-14 04:48:38 EDT
Excellent. =)  Initiating removal process for FC5.
Comment 9 Ville Skyttä 2005-10-27 14:29:37 EDT
I've prepared the three replacement packages for inclusion in Extras, will 
post them as separate "normal" Extras submissions if someone wants, but here 
are they anyway: 
 
   http://cachalot.mine.nu/4/SRPMS/perl-XML-RegExp-0.03-0.1.src.rpm 
   http://cachalot.mine.nu/4/SRPMS/perl-XML-DOM-1.44-0.1.src.rpm 
   http://cachalot.mine.nu/4/SRPMS/perl-XML-XQL-0.68-0.1.src.rpm 
 
Note: even though I packaged these, I don't really want to maintain them.  So 
I'd be inclined to just import, immediately orphan, and welcome others to take 
over. 
 
Further, now that perl-libxml-enno is gone, it looks like perl-XML-Encoding 
can be just dropped (didn't notice any more deps in Core or Extras), and 
perl-Parse-Yapp moved to Extras (apparently only needed by the new 
perl-XML-XQL). 
Comment 10 Ville Skyttä 2005-11-16 14:20:30 EST
Ouch, I see perl-XML-Encoding and perl-Parse-Yapp have been removed from 
Rawhide.  The former should be ok, but the latter causes an unsatisfied 
dependency in perl-XML-XQL in Extras, see comment 9. 
 
Is someone planning to package perl-Parse-Yapp for Extras? 
Comment 11 Ville Skyttä 2005-12-22 02:14:05 EST
perl-Parse-Yapp has been in Extras for a while; is there something left to do here?
Comment 12 Warren Togami 2006-03-06 10:34:30 EST
done

Note You need to log in before you can comment on or make changes to this bug.