Bug 1288800 - Delete not working
Delete not working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
: 1288572 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-05 21:07 EST by Steevithak
Modified: 2015-12-16 14:52 EST (History)
5 users (show)

See Also:
Fixed In Version: evolution-3.18.3-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 03:24:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steevithak 2015-12-05 21:07:50 EST
Description of problem:
I've just upgraded to Fedora 23 and in the new version of Evolution provided with it, the delete key no longer works to delete emails. Hitting delete on an email has no effect. It is still possible to delete an email by right-clicking and selecting "delete" from the context menu but it's very time consuming to delete this way. 

Version-Release number of selected component (if applicable):
3.18.2

How reproducible:
always

Steps to Reproduce:
1. Install F23
2. Start evolution
3. Try to delete an email

Actual results:
nothing happens

Expected results:
email should be deleted

Additional info:
Before you ask, yes my keyboard still works. Delete works fine in other programs and it even works within the Evolution email editor - I can delete individual characters with the delete key. It's only within Evolution's folder email listing panes (like the list of emails in the inbox for example) that delete is not working right.
Comment 1 Steevithak 2015-12-07 11:56:06 EST
Update: the up/down arrow keys also do no longer work. Looks like all operations in the email listing view have to be done via the mouse. If there's any additional information I can provide to help solve this bug, I'm happy to do it. This is super annoying! :)
Comment 2 Steevithak 2015-12-08 13:47:00 EST
I found another bug report of a similar problem:

https://bugzilla.redhat.com/show_bug.cgi?id=1288572

I've tried his work around of restarting Evolution and it works for me too. 

So, the first time Evolution is started, the keyboard actions always fail to work. If I stop and restart Evolution, the keys usually start working but only temporarily. They usually start to fail again within a few hours. It has something to do with what part of the Evolution GUI gets the focus but I can pin point exactly what actions trigger it to stop working again.
Comment 3 Steevithak 2015-12-08 14:02:08 EST
Definitely a focus problem. If I try to get keyboard navigation to work again after it stops by clicking one of the messages in the message list, the focus goes to the search bar above instead of to the message list (so hitting up down keys does stuff in the search bar instead of moving up and down the message list). So you can't get focus to return to the message list by a mouse click. Hitting tab any number of times moves focus all around Evolution but never to the message list, so you also can't get focus back on the message list by tabbing. Once the message list loses focus, the only way to get it back is to exit and restart Evolution. Then it's functional until some event causes it to lose focus.
Comment 4 Steevithak 2015-12-08 14:16:44 EST
Yay, might have found something more definite. Take a look at this upstream bug report:

https://bugzilla.gnome.org/show_bug.cgi?id=755730

I think that could be the culprit. If so, there's a fix in Evolution 3.18.3 - does anyone know when that update will be available for Fedora 23?
Comment 5 Andrea Bolognani 2015-12-09 07:16:00 EST
*** Bug 1288572 has been marked as a duplicate of this bug. ***
Comment 6 Milan Crha 2015-12-14 08:51:05 EST
Thanks for a  bug report. You found the right upstream bug (comment #4) which contains references to other related bugs as well. The 3.18.3 truly contains the fix. it had been released upstream only today. Expect it to be available in updates-testing by the end of this week the latest.
Comment 7 Fedora Update System 2015-12-14 11:44:52 EST
evolution-ews-3.18.3-1.fc23 evolution-data-server-3.18.3-1.fc23 evolution-3.18.3-1.fc23 evolution-mapi-3.18.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c122f91ce8
Comment 8 Fedora Update System 2015-12-15 05:53:05 EST
evolution-3.18.3-1.fc23, evolution-data-server-3.18.3-1.fc23, evolution-ews-3.18.3-1.fc23, evolution-mapi-3.18.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update evolution-mapi evolution-ews evolution evolution-data-server'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c122f91ce8
Comment 9 Fedora Update System 2015-12-16 03:24:01 EST
evolution-3.18.3-1.fc23, evolution-data-server-3.18.3-1.fc23, evolution-ews-3.18.3-1.fc23, evolution-mapi-3.18.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2015-12-16 09:35:09 EST
evolution-3.18.3-1.fc23, evolution-data-server-3.18.3-1.fc23, evolution-ews-3.18.3-1.fc23, evolution-mapi-3.18.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Steevithak 2015-12-16 14:52:24 EST
I received the 3.18.3 update today and so far, it's working perfectly. I think this problem is fixed! Thanks!

Note You need to log in before you can comment on or make changes to this bug.