Bug 1288801 - F23 - Opus Files not playing
Summary: F23 - Opus Files not playing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qmmp
Version: 23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Karel Volný
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-06 02:27 UTC by Gerald Cox
Modified: 2016-01-09 21:57 UTC (History)
1 user (show)

Fixed In Version: qmmp-0.9.5-1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-09 21:57:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Gerald Cox 2015-12-06 02:27:27 UTC
Description of problem:
qmmp not playing opus files, even though opus plugin is selected


Version-Release number of selected component (if applicable):
0.8.5

How reproducible:
attempt to play opus file

Actual results:
When selected, nothing happens, file will not play.  Flac version plays fine

Expected results:
opus filetypes play successfully


Additional info:
Checked that opus file was valid by playing in Juk... Juk works fine.  This may have been fixed in the newer release of qmmp.  Noticed that 0.8.5 is an old version.

Comment 1 Gerald Cox 2015-12-06 02:32:57 UTC
Found 1.0.2-1 for F24 on Koji... install this on F23... appears to be working fine.  Should probably upgrade F23 version to this.

Comment 2 Karel Volný 2015-12-08 17:10:03 UTC
(In reply to Gerald Cox from comment #0)
> Description of problem:
> qmmp not playing opus files, even though opus plugin is selected

there is a known problem which has been fixed in qmmp 0.8.7

(see http://qmmp.ylsoftware.com/view_news.php?offset=3 )

(In reply to Gerald Cox from comment #1)
> Found 1.0.2-1 for F24 on Koji... install this on F23... appears to be
> working fine.  Should probably upgrade F23 version to this.

I won't upgrade qmmp to 1.x in F23 because it uses Qt5 which is *heavily* broken

however, I'll probably rebase to latest 0.9.x while doing other fixes

(and note there is also 0.8.8 available in EPEL-7)

Comment 3 Gerald Cox 2015-12-08 18:01:28 UTC
(In reply to Karel Volný from comment #2)
> (In reply to Gerald Cox from comment #0)

> I won't upgrade qmmp to 1.x in F23 because it uses Qt5 which is *heavily*
> broken
> 
> however, I'll probably rebase to latest 0.9.x while doing other fixes
> 

Thanks for the quick response.  I'll defer to your judgement on how you want to handle it.  Just out of curiosity, what is the problem with 1.x... I've been using for several days now with F23 and haven't noticed any issues - at least not with opus and flac... and I have qmmp running most of the time.  In any event, thanks for maintaining qmmp - been a user for many years now and it's the best IMHO.

Comment 4 Karel Volný 2015-12-25 11:34:25 UTC
(In reply to Gerald Cox from comment #3)
> Thanks for the quick response.  I'll defer to your judgement on how you want
> to handle it.  Just out of curiosity, what is the problem with 1.x... I've
> been using for several days now with F23 and haven't noticed any issues - at
> least not with opus and flac... and I have qmmp running most of the time.

the issues are not with qmmp itself (i.e. the playback is okay) but rather with Qt5, so in case someone is not using any other Qt5 application, I don't want to force its usage via qmmp

the (most visible) Qt5 issues include bad font rendering and character placement, wrong screen parameters when using multiple monitors, drawing issues (leading to application hang) with some graphics etc.

> In any event, thanks for maintaining qmmp - been a user for many years now
> and it's the best IMHO.

thanks; well, somehow I've started using mplayer from the commandline almost exclusively these days, but as for graphic players, qmmp suits me the best so it was natural to get it into Fedora when I've found that missing ...

I've just built 0.9.5, if you don't mind downgrading from 1.0.2, please test and give karma once Bodhi posts the link to the update

Comment 5 Fedora Update System 2015-12-25 11:35:38 UTC
qmmp-0.9.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-26fa02a2e6

Comment 6 Gerald Cox 2015-12-26 17:46:24 UTC
(In reply to Fedora Update System from comment #5)
> qmmp-0.9.5-1.fc23 has been submitted as an update to Fedora 23.
> https://bodhi.fedoraproject.org/updates/FEDORA-2015-26fa02a2e6

Thanks...downloaded from koji and tested.  Works great.  Don't know why Bohdi is always so slow in getting things updated.  One would think 24 hours would be sufficient.  Sometimes I've noticed it takes days...

Comment 7 Gerald Cox 2015-12-26 18:06:15 UTC
Noticed you had 1.0.4 out on koji... I'm testing that also and if I notice anything will open up a rawhide bug report.  Thanks again, much appreciated!

Comment 8 Fedora Update System 2015-12-29 00:56:34 UTC
qmmp-0.9.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-26fa02a2e6

Comment 9 Fedora Update System 2015-12-29 22:45:04 UTC
qmmp-0.9.5-1.fc23 qmmp-plugin-pack-0.9.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-26fa02a2e6

Comment 10 Karel Volný 2015-12-31 13:33:14 UTC
thanks for testing; unfortunately I forgot to include the plugin-pack which needs to be updated together due to API changes ...

Comment 11 Fedora Update System 2016-01-02 18:52:26 UTC
qmmp-0.9.5-1.fc23, qmmp-plugin-pack-0.9.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-26fa02a2e6

Comment 12 Karel Volný 2016-01-04 12:23:19 UTC
thanks for re-testing

but note that bodhi comments are not the best place where to mention bugs in other versions ... to answer, well, I expect some more updates before F24 branching, so the fix should get in; if not, feel free to remind me to cherry pick the patch (or open the new bug now and hope that I'll be checking my deferred bugs queue in the right timeframe :-))

Comment 13 Fedora Update System 2016-01-09 21:57:35 UTC
qmmp-0.9.5-1.fc23, qmmp-plugin-pack-0.9.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.