Bug 1288830 - python-cups-doc depends on Python 2
Summary: python-cups-doc depends on Python 2
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-cups   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PYTHON3
TreeView+ depends on / blocked
 
Reported: 2015-12-06 12:10 UTC by Miro Hrončok
Modified: 2015-12-07 13:12 UTC (History)
2 users (show)

Fixed In Version: python-cups-1.9.72-7.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 13:12:39 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miro Hrončok 2015-12-06 12:10:36 UTC
Description of problem:
python-cups-doc (doc subpackage of python-cups) depends on /usr/bin/python (and drags Python 2 as a dependency).

Version-Release number of selected component (if applicable):
python-cups-doc-1.9.72-6.fc24

How reproducible:
Allways

Steps to Reproduce:
$ rpm -q --requires -p python-cups-doc-1.9.72-6.fc24.*.rpm 

Actual results:
/usr/bin/python
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


Expected results:
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


Additional info:
This is because a script in examples has a shebang, please remove it in %prep, teh following command should work:

sed -i '1d' examples/cupstree.py


Note You need to log in before you can comment on or make changes to this bug.