Bug 1288847 - [abrt] abiword: AP_UnixApp::catchSignals(): abiword killed by SIGABRT
[abrt] abiword: AP_UnixApp::catchSignals(): abiword killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:691a245aeb811a1fb9f35475862...
:
: 1378737 1389944 (view as bug list)
Depends On: 1387629
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2015-12-06 08:54 EST by Joachim Frieben
Modified: 2017-03-30 10:22 EDT (History)
7 users (show)

See Also:
Fixed In Version: abiword-3.0.2-3.fc24 abiword-3.0.2-3.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 01:23:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (27.56 KB, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: cgroup (259 bytes, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: core_backtrace (4.20 KB, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: dso_list (16.69 KB, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: environ (3.23 KB, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: maps (82.65 KB, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: mountinfo (3.69 KB, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: open_fds (984 bytes, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: proc_pid_status (1.18 KB, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details
File: var_log_messages (295 bytes, text/plain)
2015-12-06 08:54 EST, Joachim Frieben
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Abisource 13766 None None None 2016-05-28 15:09 EDT

  None (edit)
Description Joachim Frieben 2015-12-06 08:54:23 EST
Version-Release number of selected component:
abiword-3.0.1-4.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        abiword
crash_function: AP_UnixApp::catchSignals
executable:     /usr/bin/abiword
global_pid:     13480
kernel:         4.4.0-0.rc3.git4.1.fc24.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 AP_UnixApp::catchSignals at ap_UnixApp.cpp:1569
 #3 signalWrapper at ap_UnixApp.cpp:1512
 #5 XGetModifierMapping at ModMap.c:41
 #6 s_getAltMask at ev_UnixKeyboard.cpp:503
 #7 ev_UnixKeyboard::ev_UnixKeyboard at ev_UnixKeyboard.cpp:67
 #8 XAP_UnixFrameImpl::_initialize at xap_UnixFrameImpl.cpp:1320
 #9 XAP_Frame::initialize at xap_Frame.cpp:375
 #10 AP_UnixFrame::initialize at ap_UnixFrame.cpp:243
 #11 AP_UnixApp::newFrame at ap_UnixApp.cpp:476
 #12 AP_App::openCmdLineFiles at ap_App.cpp:69

Potential duplicate: bug 1187544
Comment 1 Joachim Frieben 2015-12-06 08:54:28 EST
Created attachment 1102782 [details]
File: backtrace
Comment 2 Joachim Frieben 2015-12-06 08:54:30 EST
Created attachment 1102783 [details]
File: cgroup
Comment 3 Joachim Frieben 2015-12-06 08:54:31 EST
Created attachment 1102784 [details]
File: core_backtrace
Comment 4 Joachim Frieben 2015-12-06 08:54:33 EST
Created attachment 1102785 [details]
File: dso_list
Comment 5 Joachim Frieben 2015-12-06 08:54:34 EST
Created attachment 1102786 [details]
File: environ
Comment 6 Joachim Frieben 2015-12-06 08:54:36 EST
Created attachment 1102787 [details]
File: limits
Comment 7 Joachim Frieben 2015-12-06 08:54:38 EST
Created attachment 1102788 [details]
File: maps
Comment 8 Joachim Frieben 2015-12-06 08:54:40 EST
Created attachment 1102789 [details]
File: mountinfo
Comment 9 Joachim Frieben 2015-12-06 08:54:41 EST
Created attachment 1102790 [details]
File: namespaces
Comment 10 Joachim Frieben 2015-12-06 08:54:43 EST
Created attachment 1102791 [details]
File: open_fds
Comment 11 Joachim Frieben 2015-12-06 08:54:44 EST
Created attachment 1102792 [details]
File: proc_pid_status
Comment 12 Joachim Frieben 2015-12-06 08:54:46 EST
Created attachment 1102793 [details]
File: var_log_messages
Comment 13 Jan Kurik 2016-02-24 09:06:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 14 mm.3abbass 2016-09-23 04:45:03 EDT
*** Bug 1378737 has been marked as a duplicate of this bug. ***
Comment 15 R P Herrold 2016-09-23 10:13:23 EDT
http://bugzilla.abisource.com/show_bug.cgi?id=13766

suggests it is a bug that Gtk should be handling
Comment 16 Hubert Figuiere 2016-10-30 09:43:05 EDT
Version 3.0.2 has been released and fix that bug
Comment 17 Gwyn Ciesla 2016-11-15 17:52:42 EST
*** Bug 1389944 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2016-11-29 21:37:10 EST
abiword-3.0.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d2e43d0928
Comment 19 Fedora Update System 2016-11-29 21:38:13 EST
abiword-3.0.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ea95a6a39f
Comment 20 Fedora Update System 2016-11-30 03:18:17 EST
abiword-3.0.2-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-673afe7e75
Comment 21 Fedora Update System 2016-11-30 03:19:03 EST
abiword-3.0.2-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-564152f164
Comment 22 Fedora Update System 2016-12-02 23:32:55 EST
abiword-3.0.2-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-564152f164
Comment 23 Fedora Update System 2016-12-03 00:39:55 EST
abiword-3.0.2-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-673afe7e75
Comment 24 Fedora Update System 2016-12-07 23:28:28 EST
abiword-3.0.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ffbf1200ab
Comment 25 Fedora Update System 2016-12-07 23:29:39 EST
abiword-3.0.2-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca183cdc57
Comment 26 Fedora Update System 2016-12-08 14:24:13 EST
abiword-3.0.2-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ffbf1200ab
Comment 27 Fedora Update System 2016-12-08 14:26:09 EST
abiword-3.0.2-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca183cdc57
Comment 28 Fedora Update System 2016-12-20 01:23:13 EST
abiword-3.0.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 29 Fedora Update System 2016-12-20 12:21:04 EST
abiword-3.0.2-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.